aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend')
-rw-r--r--meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend14
1 files changed, 6 insertions, 8 deletions
diff --git a/meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend b/meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend
index 22dae716..b26054e6 100644
--- a/meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend
+++ b/meta-openstack/recipes-support/postgresql/postgresql_9.%.bbappend
@@ -41,14 +41,12 @@ ALLOW_EMPTY_${PN}-setup = "1"
pkg_postinst_${PN}-setup () {
# postgres 9.2.4 postinst
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- /etc/init.d/postgresql-init
- if [ $? -ne 0 ]; then
- echo "[ERROR] postgres: unable to create admin account"
- exit 1
+ if [ -z "$D" ]; then
+ /etc/init.d/postgresql-init
+ if [ $? -ne 0 ]; then
+ echo "[ERROR] postgres: unable to create admin account"
+ exit 1
+ fi
fi
}