aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb')
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index e8c0fb4f..7de85e8a 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -14,12 +14,16 @@ SRCREV="7604c6701809602804e3961f7fdb201049b8c993"
PV="2.0.4+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit setuptools
+inherit setuptools pkgconfig
+
+# prevent host contamination and remove local search paths
+export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include"
DEPENDS += " \
e2fsprogs \
python-pip \
python-six \
+ yajl \
"
# RDEPENDS_default: