aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-eventlet.inc10
-rw-r--r--meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-eventlet.inc b/meta-openstack/recipes-devtools/python/python-eventlet.inc
new file mode 100644
index 00000000..fd1bf393
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-eventlet.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Highly concurrent networking library"
+HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
+
+SRC_URI[md5sum] = "8d7145af6506d5418c5a6bee7bf0b7e7"
+SRC_URI[sha256sum] = "6c9c625af48424c4680d89314dbe45a76cc990cf002489f9469ff214b044ffc1"
+
+inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb b/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
index d2878b6b..d9c9383b 100644
--- a/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
@@ -1,10 +1,2 @@
-DESCRIPTION = "Highly concurrent networking library"
-HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
-
-SRC_URI[md5sum] = "8d7145af6506d5418c5a6bee7bf0b7e7"
-SRC_URI[sha256sum] = "6c9c625af48424c4680d89314dbe45a76cc990cf002489f9469ff214b044ffc1"
-
-inherit setuptools pypi
+inherit setuptools
+require python-eventlet.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb b/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb
new file mode 100644
index 00000000..c5fe598c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-eventlet.inc