aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-warlock.inc17
-rw-r--r--meta-openstack/recipes-devtools/python/python-warlock_1.3.3.bb16
-rw-r--r--meta-openstack/recipes-devtools/python/python3-warlock_1.3.3.bb3
3 files changed, 22 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-warlock.inc b/meta-openstack/recipes-devtools/python/python-warlock.inc
new file mode 100644
index 00000000..d8a16b11
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-warlock.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Build self-validating python objects using JSON schemas"
+HOMEPAGE = "http://github.com/bcwaldon/warlock"
+SECTION = "devel/python"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS += "python-jsonschema python-jsonpatch"
+
+SRC_URI[md5sum] = "746aba989d97762948e5fca6601f283f"
+SRC_URI[sha256sum] = "a093c4d04b42b7907f69086e476a766b7639dca50d95edc83aef6aeab9db2090"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-jsonschema \
+ ${PYTHON_PN}-jsonpatch \
+ "
+
diff --git a/meta-openstack/recipes-devtools/python/python-warlock_1.3.3.bb b/meta-openstack/recipes-devtools/python/python-warlock_1.3.3.bb
index c2c694b6..3358cec9 100644
--- a/meta-openstack/recipes-devtools/python/python-warlock_1.3.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-warlock_1.3.3.bb
@@ -1,15 +1,3 @@
-DESCRIPTION = "Build self-validating python objects using JSON schemas"
-HOMEPAGE = "http://github.com/bcwaldon/warlock"
-SECTION = "devel/python"
-LICENSE = "Apache-2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-DEPENDS += "python-jsonschema python-jsonpatch"
-
-SRC_URI[md5sum] = "746aba989d97762948e5fca6601f283f"
-SRC_URI[sha256sum] = "a093c4d04b42b7907f69086e476a766b7639dca50d95edc83aef6aeab9db2090"
-
-inherit setuptools pypi
-
-RDEPENDS_${PN} += " python-jsonschema python-jsonpatch"
+inherit setuptools
+require python-warlock.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-warlock_1.3.3.bb b/meta-openstack/recipes-devtools/python/python3-warlock_1.3.3.bb
new file mode 100644
index 00000000..7f4d3508
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-warlock_1.3.3.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-warlock.inc
+