aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch34
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch b/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch
new file mode 100644
index 00000000..e7ff9cbc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch
@@ -0,0 +1,34 @@
+From 0d727a196e2fe1e13956e2417b7a325be858b2db Mon Sep 17 00:00:00 2001
+From: Bruce Ashfield <bruce.ashfield@windriver.com>
+Date: Wed, 5 Nov 2014 11:21:48 -0500
+Subject: [PATCH] websocketproxy: allow empty schemes at python 2.7.3
+
+The upstream project is concerned with a bug in empty schemes with
+2.7.3. But since Yocto is 2.7.3 and we get an empty scheme via websockify,
+no VNC consoles are possible.
+
+Rather than upreving python (big change), we aren't being hit by the
+referenced bug, so we simply make sure that the condition can never
+be true.
+
+Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
+---
+ nova/console/websocketproxy.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nova/console/websocketproxy.py b/nova/console/websocketproxy.py
+index 4d32ff4328bb..85e3ab43293f 100644
+--- a/nova/console/websocketproxy.py
++++ b/nova/console/websocketproxy.py
+@@ -45,7 +45,7 @@ class NovaProxyRequestHandlerBase(object):
+ # The nova expected behavior is to have token
+ # passed to the method GET of the request
+ parse = urlparse.urlparse(self.path)
+- if parse.scheme not in ('http', 'https'):
++ if parse.scheme not in ('http', 'https') and False:
+ # From a bug in urlparse in Python < 2.7.4 we cannot support
+ # special schemes (cf: http://bugs.python.org/issue9374)
+ if sys.version_info < (2, 7, 4):
+--
+1.9.1
+
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index a950bf86..d68725bf 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://nova-fix-location-to-doc-directory.patch \
file://nova-fix-location-to-plugin-directory.patch \
file://neutron-api-set-default-binding-vnic_type.patch \
+ file://websocketproxy-allow-empty-schemes-at-python-2.7.3.patch \
"
SRC_URI += "file://nova-all \