aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb38
1 files changed, 37 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
index 3b4636a8..7bec9804 100644
--- a/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
@@ -1,2 +1,38 @@
+DESCRIPTION = "Oslo utils"
+HOMEPAGE = "https://launchpad.net/oslo"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRCNAME = "oslo.utils"
+SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike;protocol=https"
+
+PV = "3.28.0+git${SRCPV}"
+SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c"
+S = "${WORKDIR}/git"
+
+# DEPENDS_default: python3-pip
inherit setuptools3
-require python-oslo.utils.inc
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pbr \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-iso8601 \
+ ${PYTHON_PN}-oslo.i18n \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-netaddr \
+ ${PYTHON_PN}-netifaces \
+ ${PYTHON_PN}-debtcollector \
+ ${PYTHON_PN}-pyparsing \
+ "