aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb
new file mode 100644
index 00000000..2aa318fb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.context_git.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Oslo Context Library"
+HOMEPAGE = "https://launchpad.net/oslo"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRCNAME = "oslo.context"
+SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike;protocol=https"
+
+PV = "2.17.0+git${SRCPV}"
+SRCREV = "f4b6914db02e6bcf0de4a97bbc3dc85dd6e06d91"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += " \
+ python3-pip \
+ python3-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python3-pbr-native \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ bash \
+ python3-pbr \
+ python3-debtcollector \
+ python3-positional \
+ "