aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-testtools.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-testtools.inc')
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testtools.inc b/meta-openstack/recipes-devtools/python/python-testtools.inc
new file mode 100644
index 00000000..7cc63f42
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-testtools.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Extensions to the Python standard library unit testing framework"
+HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
+
+SRC_URI[md5sum] = "0f0feb915497816cb99e39437494217e"
+SRC_URI[sha256sum] = "5827ec6cf8233e0f29f51025addd713ca010061204fdea77484a2934690a0559"
+
+inherit pypi
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-extras \
+ ${PYTHON_PN}-pbr \
+ "