aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb
new file mode 100644
index 00000000..9447744c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Plugin for setuptools that enables git integration"
+HOMEPAGE = "https://github.com/wichert/setuptools-git"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3775480a712fc46a69647678acb234cb"
+
+SRCNAME = "setuptools-git"
+
+SRC_URI = "https://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7b5967e9527c789c3113b07a1f196f6e"
+SRC_URI[sha256sum] = "047d7595546635edebef226bc566579d422ccc48a8a91c7d32d8bd174f68f831"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# conflicting file prevention
+do_install_append() {
+ rm -f ${D}${libdir}/python*/site-packages/site.py*
+}