aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb b/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb
new file mode 100644
index 00000000..33a5fc62
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.3.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Import exceptions from potentially bundled packages in requests."
+HOMEPAGE = "https://www.openstack.org/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87"
+
+SRCNAME = "requestsexceptions"
+SRC_URI = "http://pypi.io/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "85c9a2c5c5ecbd2deb0a491613fbdd12"
+SRC_URI[sha256sum] = "8f141ba636d6748cd29208c1955bde38bf00fcdda1a685bc09d8ed133700353e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# conflicting file prevention
+do_install_append() {
+ rm -f ${D}${libdir}/python*/site-packages/tests/*
+}
+
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+RDEPENDS_${PN} += " \
+ python-pbr \
+ "