aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
index b75f35d2..9994fc98 100644
--- a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
+++ b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
@@ -23,3 +23,10 @@ export BUILD_SYS
export HOST_SYS
inherit autotools distutils
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils_do_install
+}