aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb32
1 files changed, 31 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
index 416dee8d..9972d2d4 100644
--- a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
+++ b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
@@ -15,7 +15,37 @@ SRC_URI[sha256sum] = "7293c9d7e8af2e44a82f86eb9c3b058880f4bcc884bf3ad6c8a34b6498
S = "${WORKDIR}/${SRCNAME}-${PV}"
+inherit distutils
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
export BUILD_SYS
export HOST_SYS
-inherit distutils
+CONFIGUREOPTS = "--build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ --disable-silent-rules \
+ --with-libtool-sysroot=${STAGING_DIR_HOST}"
+
+do_configure () {
+ # Workaround autoconf bug
+ export ac_cv_func_malloc_0_nonnull=yes
+
+ ./configure ${CONFIGUREOPTS}
+}
+