aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb b/meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb
new file mode 100644
index 00000000..408bbdbf
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-osprofiler_2.8.2.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "OpenStack Profiler Library"
+HOMEPAGE = "http://www.openstack.org/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
+
+SRC_URI[md5sum] = "b192bdcbf201101a97d163d7ec6f4783"
+SRC_URI[sha256sum] = "525b2becd692e3c6ed77a6fdf8a9ad8a52127f18e48a3abc1264c16d7fc5208a"
+
+inherit setuptools pypi
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ python-pip \
+ python-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ python-pbr \
+ python-six \
+ python-oslo.messaging \
+ python-oslo.log \
+ python-oslo.utils \
+ python-webob \
+ python-requests \
+ python-netaddr \
+ python-oslo.concurrency \
+ "