aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb b/meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb
new file mode 100644
index 00000000..18b910bc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-debtcollector_1.21.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A collection of Python deprecation patterns and strategies that help you collect your technical debt in a non-destructive manner."
+HOMEPAGE = "http://docs.openstack.org/developer/debtcollector/"
+SECTION = "devel/python"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI[md5sum] = "ec899623b37fdee65b888243f0a46735"
+SRC_URI[sha256sum] = "f6ce5a383ad73c23e1138dbb69bf45d33f4a4bdec38f02dbf2b89477ec5e55bc"
+
+inherit setuptools pypi
+
+DEPENDS += " \
+ python-pip \
+ python-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ python-pbr \
+ python-funcsigs \
+ "