aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb b/meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb
new file mode 100644
index 00000000..8d74ace1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-debtcollector_1.17.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A collection of Python deprecation patterns and strategies that help you collect your technical debt in a non-destructive manner."
+HOMEPAGE = "http://docs.openstack.org/developer/debtcollector/"
+SECTION = "devel/python"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI[md5sum] = "d43a2733f02549628fe9f716363a5b01"
+SRC_URI[sha256sum] = "1f751d74789baa82684f55bececf754ebff1ad40e3fb1bee44fcf5c25a31e92d"
+
+inherit setuptools pypi
+
+DEPENDS += " \
+ python-pip \
+ python-pbr \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ python-pbr \
+ python-funcsigs \
+ "