aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb b/meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb
new file mode 100644
index 00000000..e24c756b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cliff_2.9.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Command Line Interface Formulation Framework"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "2bb9bc906a0174afbc25f896484d215e"
+SRC_URI[sha256sum] = "ab50fbb4717c74e32915123f4150805b463e81de1d58e43996fd813b26c5b447"
+
+inherit setuptools pypi
+
+DEPENDS += "\
+ python-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+RDEPENDS_${PN} += "python-prettytable \
+ python-cmd2 \
+ python-pbr \
+ python-pyparsing \
+ python-prettytable \
+ python-six \
+ python-stevedore \
+ python-unicodecsv \
+ python-pyyaml \
+"
+
+CLEANBROKEN = "1"