aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index a830e510..0341cacb 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -9,30 +9,25 @@ DEPENDS += " \
python-pbr \
"
-RDEPENDS_${PN} +=" \
- python-cliff \
- python-httplib2 \
- python-iso8601 \
- python-prettytable \
- python-pyparsing \
- python-simplejson \
- python-pbr \
+RDEPENDS_${PN} += " \
+ python-pbr \
+ python-iso8601 \
+ python-keystoneauth1 \
python-oslo.i18n \
python-oslo.serialization \
python-oslo.utils \
- python-keystoneclient \
+ python-prettytable \
python-requests \
python-six \
python-stevedore \
- "
+ "
SRC_URI = "\
- git://github.com/openstack/python-ceilometerclient.git;branch=master \
- file://fix_ceilometerclient_memory_leak.patch \
+ git://github.com/openstack/python-ceilometerclient.git;branch=stable/pike \
"
-PV = "1.5.0+git${SRCPV}"
-SRCREV = "daed7e59c383f1ca74d75160cbc99fbd89675648"
+PV = "2.9.0+git${SRCPV}"
+SRCREV = "4ee321feeef39fa2a297ad8e58e931b8a03d8f14"
S = "${WORKDIR}/git"
inherit setuptools rmargparse