aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-barbican_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-barbican_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 0b3d7688..579413c0 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -85,12 +85,10 @@ FILES_${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
ALLOW_EMPTY_${SRCNAME}-setup = "1"
pkg_postinst_${SRCNAME}-setup () {
- if [ "x$D" != "x" ]; then
- exit 1
+ if [ -z "$D" ]; then
+ chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
+ chown -R barbican:barbican ${localstatedir}/lib/barbican
fi
-
- chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
- chown -R barbican:barbican ${localstatedir}/lib/barbican
}
DEPENDS += " \