aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-barbican_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-barbican_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb29
1 files changed, 17 insertions, 12 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 71cf4c33..c71229d4 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -8,7 +8,7 @@ PR = "r0"
SRCNAME = "barbican"
BARBICAN_MAX_PACKET_SIZE ?= "65535"
-SRC_URI = "git://github.com/openstack/barbican.git;branch=master \
+SRC_URI = "git://github.com/openstack/barbican.git;branch=master;protocol=https \
file://barbican.init \
file://barbican-increase-buffer-size-to-support-PKI-tokens.patch \
file://barbican-fix-path-to-find-configuration-files.patch \
@@ -40,7 +40,7 @@ python () {
}
SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST"
-do_install_append() {
+do_install:append() {
TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
BARBICAN_CONF_DIR=${D}${sysconfdir}/${SRCNAME}
@@ -67,24 +67,24 @@ do_install_append() {
}
USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "--system barbican"
-USERADD_PARAM_${PN} = "--system --home /var/lib/barbican -g barbican \
+GROUPADD_PARAM:${PN} = "--system barbican"
+USERADD_PARAM:${PN} = "--system --home /var/lib/barbican -g barbican \
--no-create-home --shell /bin/false barbican"
PACKAGES += "${SRCNAME} \
${SRCNAME}-setup "
-FILES_${PN} = "${libdir}/* \
+FILES:${PN} = "${libdir}/* \
"
-FILES_${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
+FILES:${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
${sysconfdir}/init.d/barbican-api \
${bindir} \
${bindir}/* \
${localstatedir}/* \
"
-ALLOW_EMPTY_${SRCNAME}-setup = "1"
-pkg_postinst_${SRCNAME}-setup () {
+ALLOW_EMPTY:${SRCNAME}-setup = "1"
+pkg_postinst:${SRCNAME}-setup () {
if [ -z "$D" ]; then
chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
chown -R barbican:barbican ${localstatedir}/lib/barbican
@@ -96,13 +96,18 @@ DEPENDS += " \
python-pbr \
"
-RDEPENDS_${SRCNAME} = "${PN} \
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+RDEPENDS:${SRCNAME} = "${PN} \
${SRCNAME}-setup \
uwsgi \
python-falcon \
python-oslo.messaging"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python-pip \
python-pbr \
python-alembic \
@@ -126,8 +131,8 @@ RDEPENDS_${PN} += " \
"
INITSCRIPT_PACKAGES = "${SRCNAME}"
-INITSCRIPT_NAME_${SRCNAME} = "barbican-api"
-INITSCRIPT_PARAMS_${SRCNAME} = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
+INITSCRIPT_NAME:${SRCNAME} = "barbican-api"
+INITSCRIPT_PARAMS:${SRCNAME} = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
MONITOR_SERVICE_${SRCNAME} = "barbican"