aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-httpretty.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb24
3 files changed, 24 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-httpretty.inc b/meta-openstack/recipes-devtools/python/python-httpretty.inc
deleted file mode 100644
index 97bd6b3d..00000000
--- a/meta-openstack/recipes-devtools/python/python-httpretty.inc
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2014 Wind River Systems, Inc.
-#
-DESCRIPTION = "HTTP client mock for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=113a91608a1d89039af9393c39bcaa2c"
-
-SRC_URI[md5sum] = "2fc3d0dc986200be95ce8ad3ef56bc04"
-SRC_URI[sha256sum] = "66216f26b9d2c52e81808f3e674a6fb65d4bf719721394a1a9be926177e55fbe"
-
-inherit pypi
-
-DEPENDS += " \
- ${PYTHON_PN}-pip \
- "
-
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb
deleted file mode 100644
index b9f7699a..00000000
--- a/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-inherit setuptools3
-require python-httpretty.inc
-
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb
new file mode 100644
index 00000000..0b8f1927
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+#
+DESCRIPTION = "HTTP client mock for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d87f7868a62b8d598eab40164594d21b"
+
+SRC_URI[md5sum] = "1f6b9b64818837134b93839e5c7051bb"
+SRC_URI[sha256sum] = "24a6fd2fe1c76e94801b74db8f52c0fb42718dc4a199a861b305b1a492b9d868"
+
+inherit setuptools3 pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-typing \
+"