aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-httpd/apache2/apache2_2.4.%.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-openstack/recipes-httpd/apache2/apache2_2.4.%.bbappend b/meta-openstack/recipes-httpd/apache2/apache2_2.4.%.bbappend
index 7af8143f..5fc832de 100644
--- a/meta-openstack/recipes-httpd/apache2/apache2_2.4.%.bbappend
+++ b/meta-openstack/recipes-httpd/apache2/apache2_2.4.%.bbappend
@@ -1,13 +1,14 @@
do_install_append() {
sed -i -e 's/#ServerName.*$/ServerName 127.0.0.1:80/' ${D}${sysconfdir}/apache2/httpd.conf
+ # Keep our logs together, also matches ubuntu and debian
+ sed -i -e 's@^\(.*\)/var/apache2/logs\(.*\)$@\1/var/log/apache2\2@g' ${D}${sysconfdir}/apache2/httpd.conf
# default layout for htdocsdir in 2.4.7 is different, create the following for
# backward compatibility reasons
mkdir -p ${D}${datadir}/${BPN}/default-site
ln -sf ../htdocs ${D}${datadir}/${BPN}/default-site/htdocs
-
- sed -i '30i if [ ! -e /var/log/apache2 ]; then ln -sf /var/apache2/logs/ /var/log/apache2; fi' ${D}/etc/init.d/apache2
}
FILES_${PN} += "${datadir}/${BPN}/default-site"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"