aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb30
2 files changed, 15 insertions, 52 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch
deleted file mode 100644
index 137edfdb..00000000
--- a/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
----
- cinderclient/openstack/common/apiclient/client.py | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/cinderclient/openstack/common/apiclient/client.py
-+++ b/cinderclient/openstack/common/apiclient/client.py
-@@ -90,6 +90,7 @@
- self.user_agent = user_agent or self.user_agent
-
- self.times = [] # [("item", starttime, endtime), ...]
-+ self.times_max_len = 200
- self.timings = timings
-
- # requests within the same session can reuse TCP connections from pool
-@@ -142,6 +143,12 @@
- def reset_timings(self):
- self.times = []
-
-+ def get_timings_max_len(self):
-+ return self.times_max_len
-+
-+ def set_timings_max_len(self, new_len):
-+ self.times_max_len = new_len
-+
- def request(self, method, url, **kwargs):
- """Send an http request with the specified characteristics.
-
-@@ -173,6 +180,9 @@
- if self.timings:
- self.times.append(("%s %s" % (method, url),
- start_time, time.time()))
-+ # remove oldest items until we maintain max length
-+ while len(self.times) > self.times_max_len:
-+ del self.times[0]
- self._http_log_resp(resp)
-
- if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index e264694c..bf76e9d7 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -8,32 +8,32 @@ DEPENDS = "python-setuptools-git"
SRCNAME = "python-cinderclient"
SRC_URI = "\
- git://github.com/openstack/python-cinderclient.git;branch=master \
- file://fix_cinderclient_memory_leak.patch \
+ git://github.com/openstack/python-cinderclient.git;branch=stable/pike \
file://cinder-api-check.sh \
"
-PV="1.4.0+git${SRCPV}"
-SRCREV="c167dda40cc65fe437a12b815ef91bbde4efb6bb"
+PV="3.1.0+git${SRCPV}"
+SRCREV="3640aeab6e11987288a2f149fbeedb1c026045e2"
S = "${WORKDIR}/git"
-inherit setuptools monitor rmargparse
+inherit setuptools monitor
DEPENDS += " \
python-pip \
python-pbr \
"
-RDEPENDS_${PN} += "python-prettytable \
- python-simplejson \
- python-requests \
- python-setuptools-git \
- python-pbr \
- python-keystoneclient \
- python-babel \
- python-six \
- "
-
+RDEPENDS_${PN} += " \
+ python-pbr \
+ python-prettytable \
+ python-keystoneauth1 \
+ python-simplejson \
+ python-babel \
+ python-six \
+ python-oslo.i18n \
+ python-oslo.utils \
+ "
+
PACKAGECONFIG ?= "bash-completion"
PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"