aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack-swift-deploy/README48
-rw-r--r--meta-openstack-swift-deploy/conf/layer.conf9
-rw-r--r--meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend2
-rw-r--r--meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend2
4 files changed, 61 insertions, 0 deletions
diff --git a/meta-openstack-swift-deploy/README b/meta-openstack-swift-deploy/README
new file mode 100644
index 00000000..9c8acb38
--- /dev/null
+++ b/meta-openstack-swift-deploy/README
@@ -0,0 +1,48 @@
+meta-openstack-swift-deploy
+=============================
+
+This layer provides support configuring and deploying the recipes to deploy
+OpenStack Swift.
+
+Dependencies
+------------
+
+This layer depends on:
+
+URI: git://github.com/openembedded/oe-core.git
+branch: master
+revision: HEAD
+prio: default
+
+URI: git://github.com/openembedded/meta-oe.git
+patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
+revision: HEAD
+layers: meta-oe
+ meta-networking
+ meta-ruby
+
+URI: git://git.yoctoproject.org/meta-virtualization
+branch: master
+revision: head
+
+meta-openstack
+branch: master
+revision: head
+
+Maintenance
+-----------
+
+Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
+
+When sending single patches, please using something like:
+'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
+
+Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
+
+License
+-------
+
+All metadata is MIT licensed unless otherwise stated. Source code included
+in tree for individual recipes is under the LICENSE stated in each recipe
+(.bb file) unless otherwise stated.
+
diff --git a/meta-openstack-swift-deploy/conf/layer.conf b/meta-openstack-swift-deploy/conf/layer.conf
new file mode 100644
index 00000000..3f8a20b6
--- /dev/null
+++ b/meta-openstack-swift-deploy/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend ${LAYERDIR}/classes/*.bbclass"
+
+BBFILE_COLLECTIONS += "openstack-swift-deploy-layer"
+BBFILE_PATTERN_openstack-swift-deploy-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_openstack-swift-deploy-layer = "6"
diff --git a/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend b/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend
new file mode 100644
index 00000000..74f1ec66
--- /dev/null
+++ b/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend
@@ -0,0 +1,2 @@
+# Force Cinder Backup to use Swift as backend store
+CINDER_BACKUP_BACKEND_DRIVER = "cinder.backup.drivers.swift"
diff --git a/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend b/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend
new file mode 100644
index 00000000..dd3e339d
--- /dev/null
+++ b/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend
@@ -0,0 +1,2 @@
+# Force Glance to use Swift as backend store
+GLANCE_DEFAULT_STORE = "swift"