aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-waitress.inc10
-rw-r--r--meta-openstack/recipes-devtools/python/python-waitress_1.3.1.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python3-waitress_1.3.1.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-waitress.inc b/meta-openstack/recipes-devtools/python/python-waitress.inc
new file mode 100644
index 00000000..10539833
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-waitress.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Waitress WSGI server"
+HOMEPAGE = "https://pypi.python.org/pypi/waitress/"
+SECTION = "devel/python"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
+
+SRC_URI[md5sum] = "d9132d313de0c5e0fec34ef9ede5442e"
+SRC_URI[sha256sum] = "278e09d6849acc1365404bbf7d790d0423b159802e850c726e8cd0a126a2dac7"
+
+inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-waitress_1.3.1.bb b/meta-openstack/recipes-devtools/python/python-waitress_1.3.1.bb
index 78af2251..ecce64c9 100644
--- a/meta-openstack/recipes-devtools/python/python-waitress_1.3.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-waitress_1.3.1.bb
@@ -1,10 +1,2 @@
-DESCRIPTION = "Waitress WSGI server"
-HOMEPAGE = "https://pypi.python.org/pypi/waitress/"
-SECTION = "devel/python"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
-
-SRC_URI[md5sum] = "d9132d313de0c5e0fec34ef9ede5442e"
-SRC_URI[sha256sum] = "278e09d6849acc1365404bbf7d790d0423b159802e850c726e8cd0a126a2dac7"
-
-inherit setuptools pypi
+inherit setuptools
+require python-waitress.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-waitress_1.3.1.bb b/meta-openstack/recipes-devtools/python/python3-waitress_1.3.1.bb
new file mode 100644
index 00000000..89e82084
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-waitress_1.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-waitress.inc