aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-osc-lib.inc27
-rw-r--r--meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb8
3 files changed, 19 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osc-lib.inc b/meta-openstack/recipes-devtools/python/python-osc-lib.inc
index 58e994c7..05891376 100644
--- a/meta-openstack/recipes-devtools/python/python-osc-lib.inc
+++ b/meta-openstack/recipes-devtools/python/python-osc-lib.inc
@@ -7,17 +7,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
SRC_URI[md5sum] = "5e91028524b50a72f9913ccd2994cf77"
SRC_URI[sha256sum] = "9dcd3b55bd887525a7020a8adbabb661a340fc4a4a707950dc1c6f0b286cce77"
+inherit pypi
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
- python-pbr \
- python-six \
- python-babel \
- python-cliff \
- python-keystoneauth1 \
- python-os-client-config \
- python-oslo.i18n \
- python-oslo.utils \
- python-simplejson \
- python-stevedore \
+ ${PYTHON_PN}-pbr \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-babel \
+ ${PYTHON_PN}-cliff \
+ ${PYTHON_PN}-keystoneauth1 \
+ ${PYTHON_PN}-os-client-config \
+ ${PYTHON_PN}-oslo.i18n \
+ ${PYTHON_PN}-oslo.utils \
+ ${PYTHON_PN}-simplejson \
+ ${PYTHON_PN}-stevedore \
"
CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb b/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
index 4ea2de2e..d8c72e74 100644
--- a/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
@@ -1,7 +1,2 @@
-inherit setuptools pypi
+inherit setuptools
require python-osc-lib.inc
-
-# Satisfy setup.py 'setup_requires'
-DEPENDS += " \
- python-pbr-native \
- "
diff --git a/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb b/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
index 63265d9b..256c286d 100644
--- a/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
@@ -1,8 +1,2 @@
-inherit setuptools3 pypi
+inherit setuptools3
require python-osc-lib.inc
-
-# Satisfy setup.py 'setup_requires'
-DEPENDS += " \
- python3-pbr-native \
- "
-