aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-rsa.inc13
-rw-r--r--meta-openstack/recipes-devtools/python/python-rsa_3.4.2.bb15
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rsa_3.4.2.bb2
3 files changed, 17 insertions, 13 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-rsa.inc b/meta-openstack/recipes-devtools/python/python-rsa.inc
new file mode 100644
index 00000000..ccb65d5a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-rsa.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Pure-Python RSA implementation"
+AUTHOR = "Sybren A. Stuvel"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634"
+
+inherit pypi
+
+SRC_URI[md5sum] = "b315f47882c24030ee6b5aad628cccdb"
+SRC_URI[sha256sum] = "25df4e10c263fb88b5ace923dd84bf9aa7f5019687b5e55382ffcdb8bede9db5"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pyasn1 \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-rsa_3.4.2.bb b/meta-openstack/recipes-devtools/python/python-rsa_3.4.2.bb
index c7df0a8b..349e7cd9 100644
--- a/meta-openstack/recipes-devtools/python/python-rsa_3.4.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-rsa_3.4.2.bb
@@ -1,13 +1,2 @@
-SUMMARY = "Pure-Python RSA implementation"
-AUTHOR = "Sybren A. Stuvel"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634"
-
-inherit setuptools pypi
-
-SRC_URI[md5sum] = "b315f47882c24030ee6b5aad628cccdb"
-SRC_URI[sha256sum] = "25df4e10c263fb88b5ace923dd84bf9aa7f5019687b5e55382ffcdb8bede9db5"
-
-RDEPENDS_${PN} += " \
- python-pyasn1 \
- "
+inherit setuptools
+require python-rsa.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-rsa_3.4.2.bb b/meta-openstack/recipes-devtools/python/python3-rsa_3.4.2.bb
new file mode 100644
index 00000000..2d6c93ce
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-rsa_3.4.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-rsa.inc