aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-suds-jurko.inc20
-rw-r--r--meta-openstack/recipes-devtools/python/python-suds-jurko_0.6.bb21
-rw-r--r--meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb3
3 files changed, 25 insertions, 19 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-suds-jurko.inc b/meta-openstack/recipes-devtools/python/python-suds-jurko.inc
new file mode 100644
index 00000000..579212ae
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-suds-jurko.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Lightweight SOAP client (Jurko's fork)"
+HOMEPAGE = "https://bitbucket.org/jurko/suds"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=847e96bce86d8774f491a92924343a29"
+
+PYPI_PACKAGE_EXT = "tar.bz2"
+
+SRC_URI[md5sum] = "1309e9bc2454aa3434041f0a24ae4e11"
+SRC_URI[sha256sum] = "29edb72fd21e3044093d86f33c66cf847c5aaab26d64cb90e69e528ef014e57f"
+
+inherit pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS_${PN} += " \
+ "
+
diff --git a/meta-openstack/recipes-devtools/python/python-suds-jurko_0.6.bb b/meta-openstack/recipes-devtools/python/python-suds-jurko_0.6.bb
index a4a436f8..52bb6d89 100644
--- a/meta-openstack/recipes-devtools/python/python-suds-jurko_0.6.bb
+++ b/meta-openstack/recipes-devtools/python/python-suds-jurko_0.6.bb
@@ -1,20 +1,3 @@
-DESCRIPTION = "Lightweight SOAP client (Jurko's fork)"
-HOMEPAGE = "https://bitbucket.org/jurko/suds"
-SECTION = "devel/python"
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=847e96bce86d8774f491a92924343a29"
-
-PYPI_PACKAGE_EXT = "tar.bz2"
-
-SRC_URI[md5sum] = "1309e9bc2454aa3434041f0a24ae4e11"
-SRC_URI[sha256sum] = "29edb72fd21e3044093d86f33c66cf847c5aaab26d64cb90e69e528ef014e57f"
-
-inherit setuptools pypi
-
-DEPENDS += " \
- python-pip \
- "
-
-RDEPENDS_${PN} += " \
- "
+inherit setuptools
+require python-suds-jurko.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb b/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
new file mode 100644
index 00000000..d230c8de
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-suds-jurko.inc
+