aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-simplegeneric.inc12
-rw-r--r--meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb14
-rw-r--r--meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb2
3 files changed, 16 insertions, 12 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-simplegeneric.inc b/meta-openstack/recipes-devtools/python/python-simplegeneric.inc
new file mode 100644
index 00000000..2cd9fc03
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-simplegeneric.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Simple generic functions"
+HOMEPAGE = "https://pypi.python.org/pypi/simplegeneric/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.txt;md5=2085f2c228ed80422edf70e52e86c34b"
+
+PYPI_PACKAGE_EXT = "zip"
+
+SRC_URI[md5sum] = "f9c1fab00fd981be588fc32759f474e3"
+SRC_URI[sha256sum] = "dc972e06094b9af5b855b3df4a646395e43d1c9d0d39ed345b7393560d0b9173"
+
+inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb b/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
index 35c05558..5a1cc6a2 100644
--- a/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
@@ -1,12 +1,2 @@
-DESCRIPTION = "Simple generic functions"
-HOMEPAGE = "https://pypi.python.org/pypi/simplegeneric/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README.txt;md5=2085f2c228ed80422edf70e52e86c34b"
-
-PYPI_PACKAGE_EXT = "zip"
-
-SRC_URI[md5sum] = "f9c1fab00fd981be588fc32759f474e3"
-SRC_URI[sha256sum] = "dc972e06094b9af5b855b3df4a646395e43d1c9d0d39ed345b7393560d0b9173"
-
-inherit setuptools pypi
+inherit setuptools
+require python-simplegeneric.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb b/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb
new file mode 100644
index 00000000..56ad2213
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-simplegeneric.inc