aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-routes.inc15
-rw-r--r--meta-openstack/recipes-devtools/python/python-routes_git.bb17
-rw-r--r--meta-openstack/recipes-devtools/python/python3-routes_git.bb2
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-routes.inc b/meta-openstack/recipes-devtools/python/python-routes.inc
new file mode 100644
index 00000000..4224552f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-routes.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "A Python re-implementation of the Rails routes system."
+HOMEPAGE = "http://routes.groovie.org"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=90976c1a0e3029278f882cfe2e84a6ae"
+
+PV = "2.4.1+git${SRCPV}"
+SRCREV = "2dcef8079cf09f427eeb0be62374f6c1a52bf59d"
+
+SRCNAME = "Routes"
+SRC_URI = "git://github.com/bbangert/routes.git"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-repoze.lru"
diff --git a/meta-openstack/recipes-devtools/python/python-routes_git.bb b/meta-openstack/recipes-devtools/python/python-routes_git.bb
index 408f0a8f..11fea85f 100644
--- a/meta-openstack/recipes-devtools/python/python-routes_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-routes_git.bb
@@ -1,17 +1,2 @@
-DESCRIPTION = "A Python re-implementation of the Rails routes system."
-HOMEPAGE = "http://routes.groovie.org"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=90976c1a0e3029278f882cfe2e84a6ae"
-
-PV = "2.4.1+git${SRCPV}"
-SRCREV = "2dcef8079cf09f427eeb0be62374f6c1a52bf59d"
-
-SRCNAME = "Routes"
-SRC_URI = "git://github.com/bbangert/routes.git"
-
-S = "${WORKDIR}/git"
-
inherit setuptools
-
-RDEPENDS_${PN} += "python-repoze.lru"
+require python-routes.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-routes_git.bb b/meta-openstack/recipes-devtools/python/python3-routes_git.bb
new file mode 100644
index 00000000..06dd1ad7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-routes_git.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-routes.inc