aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--meta-openstack/recipes-devtools/python/python-automaton_0.8.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-castellan_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-cursive_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance-store_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glancestore_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-jsonpath-rw-ext_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-microversion-parse_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstackclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-brick_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-traits_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-vif_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-win_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.rootwrap_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.vmware_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslotest_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-rally_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-ryu_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-taskflow_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb5
-rwxr-xr-xmeta-openstack/recipes-devtools/python/python-trove_git.bb5
35 files changed, 175 insertions, 5 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 8df98298..203f9dbc 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -8,4 +8,4 @@ BBFILE_COLLECTIONS += "cloud-services-layer"
BBFILE_PATTERN_cloud-services-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_cloud-services-layer = "5"
LAYERSERIES_COMPAT_cloud-services-layer = "thud warrior"
-LAYERDEPENDS_cloud-services-layer = "core"
+LAYERDEPENDS_cloud-services-layer = "core filesystems-layer"
diff --git a/meta-openstack/recipes-devtools/python/python-automaton_0.8.0.bb b/meta-openstack/recipes-devtools/python/python-automaton_0.8.0.bb
index c7e4dda4..43a7ecfc 100644
--- a/meta-openstack/recipes-devtools/python/python-automaton_0.8.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-automaton_0.8.0.bb
@@ -13,6 +13,11 @@ DEPENDS += " \
python-pip \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-six \
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 579413c0..bf07bf3e 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -96,6 +96,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${SRCNAME} = "${PN} \
${SRCNAME}-setup \
uwsgi \
diff --git a/meta-openstack/recipes-devtools/python/python-castellan_git.bb b/meta-openstack/recipes-devtools/python/python-castellan_git.bb
index 9401ad9c..6c19b8b1 100644
--- a/meta-openstack/recipes-devtools/python/python-castellan_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-castellan_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 4b01022e..4c0780fc 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -178,6 +178,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-ply \
python-jsonpath-rw \
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 5274698b..eaea109a 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -199,6 +199,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
lvm2 \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-cursive_git.bb b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
index 1a677f12..fcdac04d 100644
--- a/meta-openstack/recipes-devtools/python/python-cursive_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
@@ -18,6 +18,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-lxml \
diff --git a/meta-openstack/recipes-devtools/python/python-glance-store_git.bb b/meta-openstack/recipes-devtools/python/python-glance-store_git.bb
index f6cfaa70..174cc7f1 100644
--- a/meta-openstack/recipes-devtools/python/python-glance-store_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance-store_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
bash \
python-oslo.config \
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 6a6cdedc..1086b2cc 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -169,6 +169,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
coreutils \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
index 0abf521f..ec59f589 100644
--- a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} = " \
python-enum34 \
python-eventlet \
diff --git a/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb b/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
index ca6a48d8..f9f33664 100644
--- a/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
@@ -13,6 +13,11 @@ DEPENDS += "\
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDPENDS_${PN} += "\
python-pbr \
"
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 5e12e873..4677d94c 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -9,6 +9,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-jsonpath-rw-ext_git.bb b/meta-openstack/recipes-devtools/python/python-jsonpath-rw-ext_git.bb
index 53cc1c45..e669e9a9 100644
--- a/meta-openstack/recipes-devtools/python/python-jsonpath-rw-ext_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-jsonpath-rw-ext_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-microversion-parse_git.bb b/meta-openstack/recipes-devtools/python/python-microversion-parse_git.bb
index d83ff002..ac768370 100644
--- a/meta-openstack/recipes-devtools/python/python-microversion-parse_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-microversion-parse_git.bb
@@ -17,6 +17,11 @@ inherit setuptools
DEPENDS += " \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
"
- \ No newline at end of file
+
diff --git a/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb b/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
index 1ac7dca1..4d7ed64f 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
@@ -18,6 +18,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-sqlalchemy \
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index a054551d..42ba1497 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -333,6 +333,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-paste \
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 3e646dfc..babbf189 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -265,6 +265,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
libvirt \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb b/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
index ce33f0cc..debc8af3 100644
--- a/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
@@ -18,6 +18,11 @@ DEPENDS += "\
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-six \
diff --git a/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb b/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb
index 12472ecb..96db3c0b 100644
--- a/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb
@@ -18,6 +18,11 @@ DEPENDS += "\
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-jsonpatch \
diff --git a/meta-openstack/recipes-devtools/python/python-os-brick_git.bb b/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
index f266f707..b76fd274 100644
--- a/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-brick_git.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
index 8d4079b1..af75b966 100644
--- a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
@@ -18,6 +18,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-six \
diff --git a/meta-openstack/recipes-devtools/python/python-os-vif_git.bb b/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
index 52fa05e9..594b6bd1 100644
--- a/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
@@ -18,6 +18,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-netaddr \
@@ -30,4 +35,4 @@ RDEPENDS_${PN} += " \
python-six \
python-stevedore \
"
- \ No newline at end of file
+
diff --git a/meta-openstack/recipes-devtools/python/python-os-win_git.bb b/meta-openstack/recipes-devtools/python/python-os-win_git.bb
index a7425060..54092c89 100644
--- a/meta-openstack/recipes-devtools/python/python-os-win_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-win_git.bb
@@ -18,6 +18,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb b/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb
index f3d54f66..c59bb9e1 100644
--- a/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
index 83504b63..d04d5d94 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
@@ -17,6 +17,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
# RDEPENDS_default:
RDEPENDS_${PN} += " \
python-oslo.log \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_git.bb
index 2dbbfe8a..23e09f1f 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
# RDEPENDS_default:
RDEPENDS_${PN} += " \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.vmware_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.vmware_git.bb
index f6e7b5eb..b2e15c3d 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.vmware_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.vmware_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-stevedore \
diff --git a/meta-openstack/recipes-devtools/python/python-oslotest_git.bb b/meta-openstack/recipes-devtools/python/python-oslotest_git.bb
index 20c0b53e..2956e599 100644
--- a/meta-openstack/recipes-devtools/python/python-oslotest_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslotest_git.bb
@@ -20,6 +20,11 @@ DEPENDS += "\
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} = "python-fixtures \
python-subunit \
python-six \
@@ -31,4 +36,4 @@ RDEPENDS_${PN} = "python-fixtures \
python-debtcollector \
bash \
"
- \ No newline at end of file
+
diff --git a/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb b/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
index a646c476..d10a7df4 100644
--- a/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
+++ b/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
@@ -9,6 +9,11 @@ SRC_URI[sha256sum] = "ab27d4efb59105555b6c9b1fe7792fd895ad9ca893058c39bba4106d6a
inherit setuptools pypi
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-lxml \
python-oslo.concurrency \
diff --git a/meta-openstack/recipes-devtools/python/python-rally_git.bb b/meta-openstack/recipes-devtools/python/python-rally_git.bb
index 31d42424..4b3109c0 100644
--- a/meta-openstack/recipes-devtools/python/python-rally_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-rally_git.bb
@@ -100,6 +100,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " python-babel \
python-decorator \
python-fixtures \
diff --git a/meta-openstack/recipes-devtools/python/python-ryu_git.bb b/meta-openstack/recipes-devtools/python/python-ryu_git.bb
index b5ee113b..08becdac 100644
--- a/meta-openstack/recipes-devtools/python/python-ryu_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ryu_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-eventlet \
python-msgpack \
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index fc7c2580..2b9c7224 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -153,6 +153,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-eventlet \
python-greenlet \
diff --git a/meta-openstack/recipes-devtools/python/python-taskflow_git.bb b/meta-openstack/recipes-devtools/python/python-taskflow_git.bb
index 1717617d..1904b560 100644
--- a/meta-openstack/recipes-devtools/python/python-taskflow_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-taskflow_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-pbr \
python-six \
@@ -37,4 +42,4 @@ RDEPENDS_${PN} += " \
python-cachetools \
python-debtcollector \
"
- \ No newline at end of file
+
diff --git a/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb b/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb
index 6260663e..15c4ad9e 100644
--- a/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb
@@ -16,6 +16,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
# RDEPENDS_default:
RDEPENDS_${PN} += " \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-trove_git.bb b/meta-openstack/recipes-devtools/python/python-trove_git.bb
index e1f8ae0b..cc6bec6d 100755
--- a/meta-openstack/recipes-devtools/python/python-trove_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-trove_git.bb
@@ -238,6 +238,11 @@ DEPENDS += " \
python-pip \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-babel \
python-cinderclient \