aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb9
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb4
10 files changed, 24 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index e6837435..469b1f7c 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -15,8 +15,8 @@ SRC_URI = "git://github.com/openstack/barbican.git;branch=master \
file://barbican-handle-white-space-in-date-strings.patch \
"
-SRCREV="ada968e162d9795613bfb346a1018f63ef7025cc"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="1000ca44f264b09c0347ac56815a4f0ef02cf0eb"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit update-rc.d setuptools identity hosts useradd default_configs openstackchef monitor
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 90ac1c6d..89f890ab 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
# file://ceilometer-builtin-tests-config-location.patch
-SRCREV="500388c3fe8be48be046908acd549f5e28608921"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="42c3d487aac5d383f5224ffc4d402387562895df"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
CEILOMETER_SECRET ?= "12121212"
@@ -104,7 +104,9 @@ do_install_append() {
install -m 0755 ${WORKDIR}/ceilometer-agent-notification.init.sh ${D}${sysconfdir}/init.d/ceilometer-agent-notification
fi
- cp setup-test-env.sh ${CEILOMETER_CONF_DIR}
+ if [ -e "setup-test-env.sh" ]; then
+ cp setup-test-env.sh ${CEILOMETER_CONF_DIR}
+ fi
}
CHEF_SERVICES_CONF_FILES :="\
@@ -138,6 +140,7 @@ PACKAGES += " ${SRCNAME}-reseller"
ALLOW_EMPTY_${SRCNAME}-setup = "1"
ALLOW_EMPTY_${SRCNAME}-reseller = "1"
+ALLOW_EMPTY_${SRCNAME}-tests = "1"
FILES_${PN} = "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 5ae149d8..acb841a9 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -20,8 +20,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://cinder-builtin-tests-config-location.patch \
"
-SRCREV="58eda5d1f41082a7e1ffef66239be30b8ac1321a"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="9ba3603d8f2cf33b33265012b2cb2480eba7b35a"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit setuptools update-rc.d identity default_configs hosts openstackchef monitor
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 53f2d5b7..fd884b5b 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -14,8 +14,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch
-SRCREV="7374d9347eeb6b354484984f06fd7e58fed50046"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="675a39a74faad5f7fe4eb94e1dcf7f4359ed2285"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 8971e417..9c1ecaeb 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://heat-tests-change-project_dir-path.patch \
"
-SRCREV="9b700a1b6e1c806d8deba64ffb9a804790765678"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="4a8cb4b2041edfa4a166b0a5dd7566874cf7c6f2"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 75127428..9bdce3f0 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -17,8 +17,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://wsgi-keystone.conf \
"
-SRCREV="73ad4036d62b3aa7cf50e11ddf7bee8278bbe4d0"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="b276f3dbc9ef1a6b2bd952c88eb45fde9b646f68"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
index f99dcd79..26bba6df 100644
--- a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
@@ -11,8 +11,8 @@ SRC_URI = "\
git://git.openstack.org/openstack/keystonemiddleware;branch=master \
"
-PV="1.1.1+git${SRCPV}"
-SRCREV="a4c13473aa09edee3c16733a4ff16f2cc206ad66"
+PV="1.2.0+git${SRCPV}"
+SRCREV="4434a77e7c679dcad1db67fba4459afa4c5c7c67"
S = "${WORKDIR}/git"
inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 6a9e66f3..677730fe 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -20,8 +20,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://uuid_wscheck.patch \
file://neutron-test-nec-plugin-extensions-location.patch \
"
-SRCREV="3cd2550f1bb20dbbc00a01d8dfd8b53e00baa00d"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="90a9e588052c1f96d9f3f0d63de3bdfa3c5b8656"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index e79302bd..86dca6f4 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -25,8 +25,8 @@ SRC_URI += "file://nova-all \
file://nova.conf \
file://openrc \
"
-SRCREV="a5f09ddddfba65b8fdc6bac994750e5980b27521"
-PV="2014.2.b3+git${SRCPV}"
+SRCREV="ba0a08c11535a9cedc07e1329e8bf729af3d4b02"
+PV="2014.2.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index bac992a9..7241be9c 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
file://cluster.conf \
"
-SRCREV="d4da726f6f45187dc053578f11246d6b36679142"
-PV="2.1.0+git${SRCPV}"
+SRCREV="6986f7272ce6b4ada209bc84f1da19602c9e6b83"
+PV="2.2.0.rc1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit setuptools python-dir update-rc.d hosts identity openstackchef