aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend2
-rw-r--r--meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend2
-rw-r--r--meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini5
-rw-r--r--meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb4
4 files changed, 8 insertions, 5 deletions
diff --git a/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend b/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
index 1c10253d..28b44ec4 100644
--- a/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
+++ b/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
@@ -1 +1 @@
-inherit compute
+inherit hosts
diff --git a/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend b/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
index d463e541..28b44ec4 100644
--- a/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
+++ b/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
@@ -1 +1 @@
-inherit controller
+inherit hosts
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini b/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini
index 7f62c061..0981afe9 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini
+++ b/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini
@@ -4,7 +4,10 @@
# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_quantum
# Replace 127.0.0.1 above with the IP address of the database used by the
# main quantum server. (Leave it as is if the database runs on this host.)
-sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/ovs_quantum
+
+# configs with listening issues, may need to use the localhost version
+# sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/ovs_quantum
+sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@%CONTROLLER_IP%/ovs_quantum
# Database reconnection retry times - in event connectivity is lost
# set to -1 implies an infinite retry count
# sql_max_retries = 10
diff --git a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
index 70094f12..34da3c9a 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "79e60ec1aef800da3a4e1841909cdd8b2cf645979d08f27bc481957c79
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools update-rc.d identity
+inherit setuptools update-rc.d identity hosts
do_install_append() {
TEMPLATE_CONF_DIR=${S}${sysconfdir}/
@@ -34,7 +34,7 @@ do_install_append() {
sed -e "s:^# core_plugin.*:core_plugin = quantum.plugins.openvswitch.ovs_quantum_plugin.OVSQuantumPluginV2:g" \
-i ${WORKDIR}/quantum.conf
- echo "rabbit_host = ${CONTROLLER_EXTERNAL_IP}" >> ${WORKDIR}/quantum.conf
+ echo "rabbit_host = ${CONTROLLER_IP}" >> ${WORKDIR}/quantum.conf
for file in ovs_quantum_plugin.ini linuxbridge_conf.ini
do