aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/classes/identity.bbclass3
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb6
2 files changed, 7 insertions, 2 deletions
diff --git a/meta-openstack/classes/identity.bbclass b/meta-openstack/classes/identity.bbclass
new file mode 100644
index 00000000..07c8efce
--- /dev/null
+++ b/meta-openstack/classes/identity.bbclass
@@ -0,0 +1,3 @@
+SERVICE_TOKEN = "password"
+SERVICE_PASSWORD = "password"
+SERVICE_TENANT_NAME = "service"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
index fc4b3a03..d6ad46d3 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "34347a3242a40d93b98c3722e6f3fbc112bc1c9ef20c045c3d40637e45
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools update-rc.d
+inherit setuptools update-rc.d identity
SERVICE_TOKEN = "password"
@@ -68,7 +68,9 @@ pkg_postinst_${SRCNAME} () {
#Create users, services and endpoints
/etc/init.d/keystone start
sleep 0.25
- bash /etc/keystone/identity.sh
+ SERVICE_PASSWORD=${SERVICE_PASSWORD} \
+ SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \
+ bash /etc/keystone/identity.sh
}
PACKAGES += " ${SRCNAME}"