aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/classes/identity.bbclass1
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb4
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-openstack/classes/identity.bbclass b/meta-openstack/classes/identity.bbclass
index b86eb76c..d1eb2764 100644
--- a/meta-openstack/classes/identity.bbclass
+++ b/meta-openstack/classes/identity.bbclass
@@ -1,4 +1,5 @@
SERVICE_TOKEN = "password"
+ADMIN_PASSWORD = "password"
SERVICE_PASSWORD = "password"
SERVICE_TENANT_NAME = "service"
DB_USER = "admin"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
index 216bfd2a..1c6e804e 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
@@ -62,11 +62,11 @@ pkg_postinst_${SRCNAME} () {
sudo -u postgres createdb keystone
keystone-manage db_sync
keystone-manage pki_setup
- # quick fix
- echo "source /etc/keystone/openrc" > /home/root/.bashrc
+
#Create users, services and endpoints
/etc/init.d/keystone start
sleep 0.25
+ ADMIN_PASSWORD=${ADMIN_PASSWORD} \
SERVICE_PASSWORD=${SERVICE_PASSWORD} \
SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \
bash /etc/keystone/identity.sh