aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-12-15 17:12:24 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-12-19 22:43:18 -0500
commit1a963389eab9f71bed2a209fe3a0c4a9d1e7a41e (patch)
treeb6dae3e9702258f3741d97754da67e36d1984dd8 /recipes-extended
parent38973e8bc393a4ca36090c58c8b6eb6d093ea69a (diff)
downloadmeta-cloud-services-1a963389eab9f71bed2a209fe3a0c4a9d1e7a41e.tar.gz
meta-cloud-services-1a963389eab9f71bed2a209fe3a0c4a9d1e7a41e.tar.bz2
meta-cloud-services-1a963389eab9f71bed2a209fe3a0c4a9d1e7a41e.zip
libibverbs: don't do battle when meta-dpdk is in play
The meta-dpdk layer has its own special version of libibverbs which will conflict with our version: Error: Transaction check error: file /usr/lib64/libibverbs.so.1.0.0 conflicts between attempted installs of \ libibverbs1-1.1.7-r0.corei7_64 and dpdk-dev-libibverbs-1.2.1+3.4+2.0.0.0-r0.corei7_64 Ensure only our version or the meta-dpdk version is in use. With current layer priorities and such this should result in the meta-dpdk version being used, which is fine since if DPDK is desired we are best using the version recommended by meta-dpdk. Users can use PREFERRED_VERSION or other tools to override the default behavior. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libibverbs/libibverbs_1.1.7.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-extended/libibverbs/libibverbs_1.1.7.bb b/recipes-extended/libibverbs/libibverbs_1.1.7.bb
index e75f90d..9fc0d6e 100644
--- a/recipes-extended/libibverbs/libibverbs_1.1.7.bb
+++ b/recipes-extended/libibverbs/libibverbs_1.1.7.bb
@@ -25,3 +25,5 @@ do_install_append() {
mkdir -p ${D}${sysconfdir}/libibverbs.d
rm -f ${D}${libdir}/libibverbs.la
}
+
+RCONFLICTS_${PN} = "dpdk-dev-libibverbs"