aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-07 15:38:35 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-08 14:17:24 -0500
commita53a25484b5afb6fbf5d1fa1ad22ffb41b8493cc (patch)
tree0ed652ad3142da94e4f6dd2d3c9e2ba6632cb2c3 /meta-openstack
parent1848f000bad47d98900ef945c76c750c3edf1a1f (diff)
downloadmeta-cloud-services-a53a25484b5afb6fbf5d1fa1ad22ffb41b8493cc.tar.gz
meta-cloud-services-a53a25484b5afb6fbf5d1fa1ad22ffb41b8493cc.tar.bz2
meta-cloud-services-a53a25484b5afb6fbf5d1fa1ad22ffb41b8493cc.zip
python-amqp: uprev to v2.2.2
This newer version is required by the new version of python-oslo.messaging found on stable/pike. Drop the old v1.4.9 so we only have the one recipe. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/conf/layer.conf1
-rw-r--r--meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb16
-rw-r--r--meta-openstack/recipes-devtools/python/python-amqp_2.1.4.bb16
-rw-r--r--meta-openstack/recipes-devtools/python/python-amqp_2.2.2.bb14
4 files changed, 14 insertions, 33 deletions
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index 61e9fb5..ceb489b 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -19,7 +19,6 @@ PREFERRED_VERSION_python-django = "1.8.6"
PREFERRED_VERSION_python-netaddr = "0.7.19"
PREFERRED_VERSION_python-sqlalchemy = "1.0.16"
PREFERRED_VERSION_python-requests = "2.13.0"
-PREFERRED_VERSION_python-amqp = "1.4.9"
PREFERRED_VERSION_python-kombu = "3.0.%"
LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb b/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb
deleted file mode 100644
index 9768e09..0000000
--- a/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Low-level AMQP client for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1702a92c723f09e3fab3583b165a8d90"
-
-SRCNAME = "amqp"
-
-SRC_URI = "https://pypi.io/packages/source/a/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "df57dde763ba2dea25b3fa92dfe43c19"
-SRC_URI[sha256sum] = "2dea4d16d073c902c3b89d9b96620fb6729ac0f7a923bbc777cb4ad827c0c61a"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-amqp_2.1.4.bb b/meta-openstack/recipes-devtools/python/python-amqp_2.1.4.bb
deleted file mode 100644
index bda166f..0000000
--- a/meta-openstack/recipes-devtools/python/python-amqp_2.1.4.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Low-level AMQP client for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
-SECTION = "devel/python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=9d6ba772ac59c08a25a12ce15bd5f27b"
-
-SRCNAME = "amqp"
-
-SRC_URI = "https://pypi.python.org/packages/23/39/06bb8bd31e78962675f696498f7821f5dbd11aa0919c5a811d83a0e02609/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "035a475e42ef4f431b4e0dca113434bd"
-SRC_URI[sha256sum] = "1378cc14afeb6c2850404f322d03dec0082d11d04bdcb0360e1b10d4e6e77ef9"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-amqp_2.2.2.bb b/meta-openstack/recipes-devtools/python/python-amqp_2.2.2.bb
new file mode 100644
index 0000000..94979d3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-amqp_2.2.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Low-level AMQP client for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9d6ba772ac59c08a25a12ce15bd5f27b"
+
+SRC_URI[md5sum] = "0971a3fd2d635ded45c349cfc17106bd"
+SRC_URI[sha256sum] = "cba1ace9d4ff6049b190d8b7991f9c1006b443a5238021aca96dd6ad2ac9da22"
+
+inherit setuptools pypi
+
+RDEPENDS_${PN} += " \
+ python-vine \
+ "