aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/webmin
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/webmin')
-rw-r--r--recipes-extended/webmin/files/disable-version-check.patch25
-rw-r--r--recipes-extended/webmin/webmin_1.620.bb (renamed from recipes-extended/webmin/webmin_1.590.bb)6
2 files changed, 18 insertions, 13 deletions
diff --git a/recipes-extended/webmin/files/disable-version-check.patch b/recipes-extended/webmin/files/disable-version-check.patch
index 585303f..a9ee405 100644
--- a/recipes-extended/webmin/files/disable-version-check.patch
+++ b/recipes-extended/webmin/files/disable-version-check.patch
@@ -1,18 +1,24 @@
-# Disable OS version check in status screen, since it is not able to
-# accurately detect the correct distro/version at the moment
-#
-# Upstream-status: Inappropriate
-#
-# Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
---- webmin-1.570.orig/webmin/webmin-lib.pl
-+++ webmin-1.570/webmin/webmin-lib.pl
-@@ -1055,17 +1055,18 @@ my %miniserv;
+Disable OS version check in status screen
+
+The code is not able to accurately detect the correct distro/version at
+the moment.
+
+Upstream-status: Inappropriate
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/webmin/webmin-lib.pl b/webmin/webmin-lib.pl
+index 57a37f7..838b944 100755
+--- a/webmin/webmin-lib.pl
++++ b/webmin/webmin-lib.pl
+@@ -1059,18 +1059,19 @@ my %miniserv;
&load_theme_library(); # So that UI functions work
# Need OS upgrade
-my %realos = &detect_operating_system(undef, 1);
-if (($realos{'os_version'} ne $gconfig{'os_version'} ||
- $realos{'os_type'} ne $gconfig{'os_type'}) &&
+- $realos{'os_version'} && $realos{'os_type'} &&
- &foreign_available("webmin")) {
- push(@notifs,
- &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi").
@@ -25,6 +31,7 @@
+#my %realos = &detect_operating_system(undef, 1);
+#if (($realos{'os_version'} ne $gconfig{'os_version'} ||
+# $realos{'os_type'} ne $gconfig{'os_type'}) &&
++# $realos{'os_version'} && $realos{'os_type'} &&
+# &foreign_available("webmin")) {
+# push(@notifs,
+# &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi").
diff --git a/recipes-extended/webmin/webmin_1.590.bb b/recipes-extended/webmin/webmin_1.620.bb
index c2d593a..59c0e38 100644
--- a/recipes-extended/webmin/webmin_1.590.bb
+++ b/recipes-extended/webmin/webmin_1.620.bb
@@ -9,8 +9,6 @@ RDEPENDS_${PN} += "perl-module-warnings perl-module-xsloader perl-module-posix p
RDEPENDS_${PN} += "perl-module-fcntl perl-module-tie-hash perl-module-vars perl-module-time-local perl-module-config perl-module-constant"
RDEPENDS_${PN} += "perl-module-file perl-module-file-glob perl-module-file-copy perl-module-sdbm perl-module-sdbm-file perl-module-timelocal perl-module-feature"
-PR = "r1"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \
file://setup.sh \
file://init-exclude.patch \
@@ -25,8 +23,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \
file://net-lib.pl.patch \
file://media-tomb.patch"
-SRC_URI[md5sum] = "815005ed7f208dcfbda5308b446779c2"
-SRC_URI[sha256sum] = "07b06612a8bc864388d86b55ec9a9adba0fa71ec60cc66d87c0e58280264182d"
+SRC_URI[md5sum] = "e93bc5057a5b7d7e31ecb2bb228d7044"
+SRC_URI[sha256sum] = "3d36153406d8e5d3dcaeadba34dfb5cdbc4060b75c38339174ac97b2277f284b"
inherit allarch perlnative update-rc.d