aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/ffmpeg/ffmpegthumbnailer/include-cstring.patch25
-rw-r--r--recipes-multimedia/ffmpeg/ffmpegthumbnailer_2.0.8.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-multimedia/ffmpeg/ffmpegthumbnailer/include-cstring.patch b/recipes-multimedia/ffmpeg/ffmpegthumbnailer/include-cstring.patch
new file mode 100644
index 0000000..f73d3c5
--- /dev/null
+++ b/recipes-multimedia/ffmpeg/ffmpegthumbnailer/include-cstring.patch
@@ -0,0 +1,25 @@
+Upstream-Status: Accepted
+
+libpng headers after 1.6.0 do not include cstring.
+Include cstring in pngwriter.cpp to make memcpy available.
+
+Signed-off-by: Kevin Strasser <kevin.strasser@linux.intel.com>
+---
+ libffmpegthumbnailer/pngwriter.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libffmpegthumbnailer/pngwriter.cpp b/libffmpegthumbnailer/pngwriter.cpp
+index 1d40b1c..6648265 100644
+--- a/libffmpegthumbnailer/pngwriter.cpp
++++ b/libffmpegthumbnailer/pngwriter.cpp
+@@ -17,6 +17,7 @@
+ #include "pngwriter.h"
+ #include <stdexcept>
+ #include <cassert>
++#include <cstring>
+
+ using namespace std;
+
+--
+1.7.9.5
+
diff --git a/recipes-multimedia/ffmpeg/ffmpegthumbnailer_2.0.8.bb b/recipes-multimedia/ffmpeg/ffmpegthumbnailer_2.0.8.bb
index 82a35e1..e16dcd9 100644
--- a/recipes-multimedia/ffmpeg/ffmpegthumbnailer_2.0.8.bb
+++ b/recipes-multimedia/ffmpeg/ffmpegthumbnailer_2.0.8.bb
@@ -4,7 +4,8 @@ HOMEPAGE = "http://code.google.com/p/ffmpegthumbnailer/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
-SRC_URI = "http://ffmpegthumbnailer.googlecode.com/files/${PN}-${PV}.tar.gz"
+SRC_URI = "http://ffmpegthumbnailer.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://include-cstring.patch"
DEPENDS = "ffmpeg jpeg libpng"