aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-installer/anaconda/files/0006-livepayload-fix-mount-install-tree-failed.patch35
-rwxr-xr-xrecipes-installer/anaconda/python3-anaconda_30.25.6.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-installer/anaconda/files/0006-livepayload-fix-mount-install-tree-failed.patch b/recipes-installer/anaconda/files/0006-livepayload-fix-mount-install-tree-failed.patch
new file mode 100644
index 0000000..6cf2e23
--- /dev/null
+++ b/recipes-installer/anaconda/files/0006-livepayload-fix-mount-install-tree-failed.patch
@@ -0,0 +1,35 @@
+From f16dbbd6d1d3c407beafdf49e01fcd7744c51111 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Sat, 6 Jul 2019 11:05:11 +0800
+Subject: [PATCH] livepayload: fix mount install tree failed
+
+...
+ File "/usr/lib64/python3.7/site-packages/pyanaconda/payload/livepayload.py", line 85, in setup
+ raise PayloadInstallError("Failed to mount the install tree")
+...
+
+Try mounting with noload
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ pyanaconda/payload/livepayload.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyanaconda/payload/livepayload.py b/pyanaconda/payload/livepayload.py
+index 6a8d345..c8df0cd 100644
+--- a/pyanaconda/payload/livepayload.py
++++ b/pyanaconda/payload/livepayload.py
+@@ -80,7 +80,7 @@ class LiveImagePayload(Payload):
+ (self.data.method.partition,))
+ if errorHandler.cb(exn) == ERROR_RAISE:
+ raise exn
+- rc = payload_utils.mount(osimg.path, INSTALL_TREE, fstype="auto", options="ro")
++ rc = payload_utils.mount(osimg.path, INSTALL_TREE, fstype="auto", options="ro,noload")
+ if rc != 0:
+ raise PayloadInstallError("Failed to mount the install tree")
+
+--
+2.7.4
+
diff --git a/recipes-installer/anaconda/python3-anaconda_30.25.6.bb b/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
index f1ccc40..e9e83f4 100755
--- a/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
+++ b/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
@@ -55,6 +55,7 @@ SRC_URI = "git://github.com/rhinstaller/anaconda;protocol=https;branch=f30-relea
file://0003-tweak-iso-mount-dir-and-kernel-name.patch \
file://0004-customize-default-option-for-OE.patch \
file://0005-anaconda.conf-set-luks1-for-encrypt-filesystem.patch \
+ file://0006-livepayload-fix-mount-install-tree-failed.patch \
file://0007-dnfpayload.py-customize-for-OE.patch \
file://0009-dynamic-detect-workable-locale.patch \
file://0010-reboot-unconditionally.patch \