aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-installer/anaconda/files/0004-customize-default-option-for-OE.patch41
-rw-r--r--recipes-installer/anaconda/files/0020-do-not-verify-ssl-certification-by-default.patch44
-rwxr-xr-xrecipes-installer/anaconda/python3-anaconda_30.25.6.bb2
3 files changed, 42 insertions, 45 deletions
diff --git a/recipes-installer/anaconda/files/0004-customize-default-option-for-OE.patch b/recipes-installer/anaconda/files/0004-customize-default-option-for-OE.patch
new file mode 100644
index 0000000..539032b
--- /dev/null
+++ b/recipes-installer/anaconda/files/0004-customize-default-option-for-OE.patch
@@ -0,0 +1,41 @@
+From 06081bd53399b6c71c373a13bffc6ea990e833b0 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 25 Jun 2019 10:52:52 +0800
+Subject: [PATCH] customize default option for OE
+
+- Do not verify ssl certification by default
+
+- Disable selinux by default
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ pyanaconda/argument_parsing.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pyanaconda/argument_parsing.py b/pyanaconda/argument_parsing.py
+index b520509..bd1eda8 100644
+--- a/pyanaconda/argument_parsing.py
++++ b/pyanaconda/argument_parsing.py
+@@ -462,7 +462,7 @@ def getArgumentParser(version_string, boot_cmdline=None):
+ help=help_parser.help_text("stage2"))
+ ap.add_argument("--addrepo", dest="addRepo", default=[], metavar="NAME,ADDITIONAL_REPO_URL",
+ action="append", help=help_parser.help_text("addrepo"))
+- ap.add_argument("--noverifyssl", action="store_true", default=False,
++ ap.add_argument("--noverifyssl", action="store_true", default=True,
+ help=help_parser.help_text("noverifyssl"))
+ ap.add_argument("--liveinst", action="store_true", default=False,
+ help=help_parser.help_text("liveinst"))
+@@ -500,7 +500,7 @@ def getArgumentParser(version_string, boot_cmdline=None):
+ from pykickstart.constants import SELINUX_DISABLED, SELINUX_ENFORCING
+ from pyanaconda.core.constants import SELINUX_DEFAULT
+ ap.add_argument("--noselinux", dest="selinux", action="store_const",
+- const=SELINUX_DISABLED, default=SELINUX_DEFAULT,
++ const=SELINUX_DISABLED, default=SELINUX_DISABLED,
+ help=help_parser.help_text("noselinux"))
+
+ # Use a custom action to convert --selinux=0 and --selinux=1 into the
+--
+2.7.4
+
diff --git a/recipes-installer/anaconda/files/0020-do-not-verify-ssl-certification-by-default.patch b/recipes-installer/anaconda/files/0020-do-not-verify-ssl-certification-by-default.patch
deleted file mode 100644
index 93fc2e6..0000000
--- a/recipes-installer/anaconda/files/0020-do-not-verify-ssl-certification-by-default.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 8d9e5b9eeeff0aa3bb8257c203618899a684ac9a Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Tue, 24 Jul 2018 14:09:02 +0800
-Subject: [PATCH 20/65] do not verify ssl certification by default
-
-It is helpful for development that use private certification.
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- pyanaconda/argument_parsing.py | 2 +-
- pyanaconda/flags.py | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pyanaconda/argument_parsing.py b/pyanaconda/argument_parsing.py
-index 38c1601..b4c4315 100644
---- a/pyanaconda/argument_parsing.py
-+++ b/pyanaconda/argument_parsing.py
-@@ -446,7 +446,7 @@ def getArgumentParser(version_string, boot_cmdline=None):
- help=help_parser.help_text("repo"))
- ap.add_argument("--stage2", dest="stage2", default=None, metavar="STAGE2_URL",
- help=help_parser.help_text("stage2"))
-- ap.add_argument("--noverifyssl", action="store_true", default=False,
-+ ap.add_argument("--noverifyssl", action="store_true", default=True,
- help=help_parser.help_text("noverifyssl"))
- ap.add_argument("--liveinst", action="store_true", default=False,
- help=help_parser.help_text("liveinst"))
-diff --git a/pyanaconda/flags.py b/pyanaconda/flags.py
-index 2566d46..d797d2c 100644
---- a/pyanaconda/flags.py
-+++ b/pyanaconda/flags.py
-@@ -54,7 +54,7 @@ class Flags(object):
- self.debug = False
- self.armPlatform = None
- self.preexisting_x11 = False
-- self.noverifyssl = False
-+ self.noverifyssl = True
- self.imageInstall = False
- self.automatedInstall = False
- self.dirInstall = False
---
-2.7.4
-
diff --git a/recipes-installer/anaconda/python3-anaconda_30.25.6.bb b/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
index 5e36f4d..5bfd933 100755
--- a/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
+++ b/recipes-installer/anaconda/python3-anaconda_30.25.6.bb
@@ -52,6 +52,7 @@ SRC_URI = "git://github.com/rhinstaller/anaconda;protocol=https;branch=f30-relea
file://0001-do-not-build-po-and-doc.patch \
file://0002-do-not-load-the-system-wide-Xresources.patch \
file://0003-tweak-iso-mount-dir-and-kernel-name.patch \
+ file://0004-customize-default-option-for-OE.patch \
file://0007-dnfpayload.py-customize-for-OE.patch \
file://0009-dynamic-detect-workable-locale.patch \
file://0011-disable-audit.patch \
@@ -61,7 +62,6 @@ SRC_URI = "git://github.com/rhinstaller/anaconda;protocol=https;branch=f30-relea
file://0017-invisible-help-button.patch \
file://0018-disable-non-implemented-functions.patch \
file://0019-support-UEFI-boot.patch \
- file://0020-do-not-verify-ssl-certification-by-default.patch \
file://0021-tweak-default-nfs-mount-point.patch \
file://0022-fix-quoted-empty-string-failed.patch \
file://0023-do-not-support-ISO-hold-by-hard-drive-partitions.patch \