aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000')
-rw-r--r--meta-v1000/conf/local.conf.append.v100027
-rw-r--r--meta-v1000/conf/machine/v1000.conf5
-rw-r--r--meta-v1000/recipes-support/opencv/opencv_%.bbappend2
3 files changed, 27 insertions, 7 deletions
diff --git a/meta-v1000/conf/local.conf.append.v1000 b/meta-v1000/conf/local.conf.append.v1000
index 4c5658ec..34518aa6 100644
--- a/meta-v1000/conf/local.conf.append.v1000
+++ b/meta-v1000/conf/local.conf.append.v1000
@@ -40,10 +40,25 @@ COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "commercial_gstreamer1.0-plugins-ugly \
LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
CORE_IMAGE_EXTRA_INSTALL_append = "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-# MEL has support for Vulkan/LunarG SDK components.
-# These components are required to run the Vulkan based applications.
-# In order to include these components in your final
-# image or generating an ADE that can be used to develop for/against these
-# please change the below define to "yes" before building the
-# image or generating ADE.
+# MEL supports various components that can be enabled by setting the corresponding
+# INCLUDE_<component> to "yes".
+# Following is a list of <components> that can be enabled if you want them to be
+# installed/available on your image.
+# Please change the required INCLUDE_<component> to "yes" before building an image, or
+# generating an ADE that can be used to develop apps for these components (if applicable):
+#
+# - VULKAN - Vulkan driver and Loader Layer.
+# It is required to run Vulkan based applications. Vulkan is a new generation graphics
+# and compute API that provides high-efficiency, cross-platform access to modern GPUs.
+#
+# - OPENCL - The Open Computing Language.
+# Framework for writing programs that execute across heterogeneous platforms consisting
+# of CPUs, GPUs, DSPs, FPGAs and other processors or hardware accelerators.
+#
+# - OPENCV - The Open Computer Vision Library.
+# Library of programming functions mainly aimed at real-time computer vision. Used for
+# image-processing on input from image/video files and camera etc.
+#
INCLUDE_VULKAN ??= "no"
+INCLUDE_OPENCL ??= "no"
+INCLUDE_OPENCV ??= "no"
diff --git a/meta-v1000/conf/machine/v1000.conf b/meta-v1000/conf/machine/v1000.conf
index 6fd71d22..27215d63 100644
--- a/meta-v1000/conf/machine/v1000.conf
+++ b/meta-v1000/conf/machine/v1000.conf
@@ -14,7 +14,10 @@ require conf/machine/include/tune-v1000.inc
# Add machine specific AMD features and feature pkgs here
VULKAN_PKGS_v1000 = "amdvlk glslang spirv-tools vulkan-loader-layers rgp"
-AMD_PLATFORM_SPECIFIC_PKGS_v1000 += "opencl"
+AMD_PLATFORM_SPECIFIC_PKGS_v1000 += " \
+ ${@bb.utils.contains('INCLUDE_OPENCL', 'yes', 'opencl', '', d)} \
+ ${@bb.utils.contains('INCLUDE_OPENCV', 'yes', 'opencv', '', d)} \
+ "
include conf/machine/include/amd-common-configurations.inc
include conf/machine/include/amd-customer-configurations.inc
diff --git a/meta-v1000/recipes-support/opencv/opencv_%.bbappend b/meta-v1000/recipes-support/opencv/opencv_%.bbappend
new file mode 100644
index 00000000..926175c4
--- /dev/null
+++ b/meta-v1000/recipes-support/opencv/opencv_%.bbappend
@@ -0,0 +1,2 @@
+# We do not support Video4Linux
+PACKAGECONFIG_remove_v1000 = " v4l libv4l"