aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch')
-rw-r--r--meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch b/meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch
new file mode 100644
index 00000000..1ffc283e
--- /dev/null
+++ b/meta-v1000/recipes-graphics/vulkan/vulkan-loader-layers/0002-demos-CMakeLists.txt-install-demos.patch
@@ -0,0 +1,35 @@
+From 0ee0a0502b96b46190f6e47243b0a008ff04ebbd Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 4 Sep 2018 14:10:37 +0500
+Subject: [PATCH 2/5] demos/CMakeLists.txt: install demos
+
+Install demos to the target.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ demos/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt
+index fb5022bf5..5a723805d 100644
+--- a/demos/CMakeLists.txt
++++ b/demos/CMakeLists.txt
+@@ -148,6 +148,7 @@ if(NOT WIN32)
+ if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL ${CMAKE_HOST_SYSTEM_PROCESSOR})
+ add_executable(cube cube.c ${PROJECT_SOURCE_DIR}/demos/cube.vert ${PROJECT_SOURCE_DIR}/demos/cube.frag cube.vert.inc cube.frag.inc)
+ target_link_libraries(cube ${LIBRARIES})
++ install(TARGETS cube DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+ else()
+ if (CMAKE_CL_64)
+@@ -164,6 +165,7 @@ if(NOT WIN32)
+ if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL ${CMAKE_HOST_SYSTEM_PROCESSOR})
+ add_executable(cubepp cube.cpp ${PROJECT_SOURCE_DIR}/demos/cube.vert ${PROJECT_SOURCE_DIR}/demos/cube.frag cube.vert.inc cube.frag.inc)
+ target_link_libraries(cubepp ${LIBRARIES})
++ install(TARGETS cubepp DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+ else()
+ if (CMAKE_CL_64)
+--
+2.11.1
+