aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch')
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch63
1 files changed, 0 insertions, 63 deletions
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch
deleted file mode 100644
index 5066dcfb..00000000
--- a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 397088b60fa8f8078d633a7924eb2d5978dc5067 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 6 Dec 2017 18:29:32 +0500
-Subject: [PATCH] install samples
-
-The samples are built but not installed correctly. This
-fixes the issues and deploys all the built samples as
-necessary.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- API-Samples/CMakeLists.txt | 4 ++++
- Sample-Programs/Hologram/CMakeLists.txt | 1 +
- 2 files changed, 5 insertions(+)
-
-diff --git a/API-Samples/CMakeLists.txt b/API-Samples/CMakeLists.txt
-index ebec4a092..7098045de 100644
---- a/API-Samples/CMakeLists.txt
-+++ b/API-Samples/CMakeLists.txt
-@@ -70,6 +70,7 @@ function(sampleExtGLSLShaders SNAME)
- endforeach(SFILE)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp ${SHADER_FILES})
- target_link_libraries(${SAMPLE_NAME} ${VULKAN_LOADER} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- endfunction(sampleExtGLSLShaders)
-
- # function to build a single-source-file sample that uses spirv shaders
-@@ -83,6 +84,7 @@ function(sampleExtSPIRVShaders SNAME)
- endforeach(SFILE)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp ${SHADER_FILES})
- target_link_libraries(${SAMPLE_NAME} ${VULKAN_LOADER} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- endfunction(sampleExtSPIRVShaders)
-
- # function to build a simple single-source-file sample
-@@ -149,6 +151,7 @@ function(sampleWithSingleFile)
- elseif(UNIX)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${XCB_LIBRARIES} ${WAYLAND_CLIENT_LIBRARIES} ${VULKAN_LOADER} ${PTHREAD} ${SPIRV_TOOLS_LIBRARIES})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- else()
- add_executable(${SAMPLE_NAME} WIN32 ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${VULKAN_LOADER} ${WINLIBS} ${SPIRV_TOOLS_LIBRARIES})
-@@ -170,6 +173,7 @@ function(sampleInlineGLSLShaders)
- if(UNIX)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${GLSLANG_LIBRARIES} ${XCB_LIBRARIES} ${VULKAN_LOADER} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- else()
- add_executable(${SAMPLE_NAME} WIN32 ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${GLSLANG_LIBRARIES} ${VULKAN_LOADER} ${WINLIBS})
-diff --git a/Sample-Programs/Hologram/CMakeLists.txt b/Sample-Programs/Hologram/CMakeLists.txt
-index 11e007eaa..a03b0d06c 100644
---- a/Sample-Programs/Hologram/CMakeLists.txt
-+++ b/Sample-Programs/Hologram/CMakeLists.txt
-@@ -92,3 +92,4 @@ add_executable(Hologram ${sources})
- target_compile_definitions(Hologram ${definitions})
- target_include_directories(Hologram ${includes})
- target_link_libraries(Hologram ${libraries})
-+install(TARGETS Hologram DESTINATION ${CMAKE_INSTALL_BINDIR})
---
-2.11.1
-