aboutsummaryrefslogtreecommitdiffstats
path: root/meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb')
-rw-r--r--meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb b/meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb
new file mode 100644
index 00000000..b124e12c
--- /dev/null
+++ b/meta-steppeeagle/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Configuration file to pass module load parameters to AMD Watchdog driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "file://modprobe.d/amd-wdt.conf"
+
+PR = "r0"
+PV = "1.0"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/modprobe.d/
+ install -m 0644 modprobe.d/amd-wdt.conf ${D}${sysconfdir}/modprobe.d/
+}
+
+FILES_${PN} = "${sysconfdir}/modprobe.d"
+