aboutsummaryrefslogtreecommitdiffstats
path: root/meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb')
-rw-r--r--meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb b/meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb
new file mode 100644
index 00000000..e0e0999d
--- /dev/null
+++ b/meta-steppeeagle/recipes-kernel/linux-firmware/radeon-firmware.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "These binaries provide kernel support for AMD radeon GPUs"
+SECTION = "kernel"
+LICENSE = "Proprietary"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI = "file://*.bin"
+
+LIC_FILES_CHKSUM = "file://LICENSE.radeon;md5=07b0c31777bd686d8e1609c6940b5e74"
+
+S = "${WORKDIR}"
+
+# Since, no binaries are generated for a specific target,
+# inherit allarch to simply populate prebuilt binaries
+inherit allarch
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -v -m 444 -D ${S}/LICENSE.radeon ${D}/lib/firmware/radeon/LICENSE.radeon
+ install -v -m 0644 ${S}/*.bin ${D}/lib/firmware/radeon/
+}
+
+FILES_${PN} = "/lib/firmware/*"