aboutsummaryrefslogtreecommitdiffstats
path: root/meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb')
-rw-r--r--meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb b/meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb
new file mode 100644
index 00000000..2347b74d
--- /dev/null
+++ b/meta-steppeeagle/recipes-applications/smbus-test/smbus-test_1.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Sample application for AMD SMBUS driver"
+SECTION = "applications"
+LICENSE = "BSD | GPLv2"
+DEPENDS = "readline"
+LIC_FILES_CHKSUM = "file://smbus-test.c;md5=51840771157718d4d562329e476d6917 \
+ file://i2c-dev.h;md5=11afa8583cd78137a63feb1a8b24cc51 \
+ "
+
+PR = "r1"
+PV = "1.0"
+
+SRC_URI = "file://smbus-test.c \
+ file://i2c-dev.h \
+ "
+
+S = "${WORKDIR}"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+ ${CC} smbus-test.c -o smbus-test -lreadline
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 smbus-test ${D}${bindir}
+}