aboutsummaryrefslogtreecommitdiffstats
path: root/meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb')
-rw-r--r--meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb b/meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb
new file mode 100644
index 00000000..868c63c9
--- /dev/null
+++ b/meta-steppeeagle/recipes-applications/rtc-test/rtc-test_1.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Sample application for AMD RTC driver"
+SECTION = "applications"
+LICENSE = "BSD"
+DEPENDS = "readline"
+LIC_FILES_CHKSUM = "file://rtc-test.c;md5=cdf9bfd59714d20025056dbfaaf31134"
+
+PR = "r1"
+PV = "1.0"
+
+SRC_URI = "file://rtc-test.c"
+
+S = "${WORKDIR}"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+ ${CC} rtc-test.c -o rtc-test -lreadline
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 rtc-test ${D}${bindir}
+}