aboutsummaryrefslogtreecommitdiffstats
path: root/meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb')
-rw-r--r--meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb b/meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb
new file mode 100644
index 00000000..246a1c97
--- /dev/null
+++ b/meta-steppeeagle/recipes-applications/gpio-test/gpio-test_1.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Sample application for AMD GPIO driver"
+SECTION = "applications"
+LICENSE = "BSD"
+DEPENDS = "readline"
+LIC_FILES_CHKSUM = "file://gpio-test.c;md5=cd7d02789bf5b4795b385ad4f2938469 \
+ file://gpio-test.h;md5=c7aaa743b172cf584032f9bfc5e85044 \
+ "
+
+PR = "r1"
+PV = "1.0"
+
+SRC_URI = "file://gpio-test.c \
+ file://gpio-test.h \
+ "
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} gpio-test.c -o gpio-test -lreadline
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 gpio-test ${D}${bindir}
+}