aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86')
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang/0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch14
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb2
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch27
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools_git.bb7
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0002-layers-obey-CXX_FLAGS.patch32
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0004-install-the-vulkan-loader.patch2
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0005-install-demos.patch7
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0006-json-correct-layer-lib-paths.patch14
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0007-obey-CMAKE_INSTALL_PREFIX.patch31
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0008-demos-make-shader-location-relative.patch10
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.26.bb (renamed from meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.21.bb)4
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0003-obey-CMAKE_INSTALL_PREFIX.patch31
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.26.bb (renamed from meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.21.bb)5
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch24
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0004-json-correct-layer-lib-paths.patch16
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0005-obey-CMAKE_INSTALL_PREFIX.patch31
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0006-vktrace-disable-Qt5-for-now.patch30
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb (renamed from meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.21.bb)6
18 files changed, 92 insertions, 201 deletions
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang/0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang/0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch
index a7a48692..cef3e8e6 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang/0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang/0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch
@@ -1,6 +1,6 @@
-From a94776800bed66cf078c056f85c7fe5417b87784 Mon Sep 17 00:00:00 2001
+From 372422ed8ce32e1085cd524156c687df65095237 Mon Sep 17 00:00:00 2001
From: Awais Belal <awais_belal@mentor.com>
-Date: Fri, 12 Aug 2016 18:47:07 +0500
+Date: Tue, 25 Oct 2016 14:44:20 +0500
Subject: [PATCH] CMakeLists.txt: obey CMAKE_INSTALL_LIBDIR
Not using the exact path that is set through cmake
@@ -28,20 +28,20 @@ index 4954db9..6b518d9 100644
- ARCHIVE DESTINATION lib)
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/SPIRV/CMakeLists.txt b/SPIRV/CMakeLists.txt
-index 5c169b1..145b9e3 100755
+index 48a6c46..c657d56 100755
--- a/SPIRV/CMakeLists.txt
+++ b/SPIRV/CMakeLists.txt
-@@ -26,4 +26,4 @@ if(WIN32)
+@@ -41,4 +41,4 @@ if(WIN32)
endif(WIN32)
- install(TARGETS SPIRV
+ install(TARGETS SPIRV SPVRemapper
- ARCHIVE DESTINATION lib)
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
-index f431cc1..003e6c7 100644
+index ff91135..efb7f15 100644
--- a/glslang/CMakeLists.txt
+++ b/glslang/CMakeLists.txt
-@@ -88,4 +88,4 @@ if(WIN32)
+@@ -89,4 +89,4 @@ if(WIN32)
endif(WIN32)
install(TARGETS glslang
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
index 2dad75ee..0ddd1efa 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://glslang/Include/Types.h;beginline=1;endline=36;md5=66
S = "${WORKDIR}/git"
-SRCREV = "e4821e43c86d97bcf65fb07c1f70471b7102978d"
+SRCREV = "81cd764b5ffc475bc73f1fb35f75fd1171bb2343"
SRC_URI = "git://github.com/KhronosGroup/glslang \
file://0001-CMakeLists.txt-obey-CMAKE_INSTALL_LIBDIR.patch"
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
new file mode 100644
index 00000000..2d51f2fd
--- /dev/null
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
@@ -0,0 +1,27 @@
+From 93a770330aa21c91a9b7fce798b73d31cad8f16a Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 25 Oct 2016 16:12:08 +0500
+Subject: [PATCH] spirv-lesspipe.sh: allow using generic shells
+
+The script is harmless for any type of shell and
+shouldn't be tied with bash to allow catering
+more possibilities.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ tools/lesspipe/spirv-lesspipe.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/lesspipe/spirv-lesspipe.sh b/tools/lesspipe/spirv-lesspipe.sh
+index 05831d1..4e98fee 100644
+--- a/tools/lesspipe/spirv-lesspipe.sh
++++ b/tools/lesspipe/spirv-lesspipe.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # Copyright (c) 2016 The Khronos Group Inc.
+ #
+--
+1.9.1
+
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools_git.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools_git.bb
index e7650e26..f9563366 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools_git.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/spirv-tools_git.bb
@@ -14,11 +14,12 @@ S = "${WORKDIR}/git"
SPIRV_HEADERS_LOCATION = "${S}/external/spirv-headers"
HEADERS_VERSION = "1.1"
-SRCREV_spirv-tools = "6c61bf2dfadf70ab5fe1b0fb918ba03b7afa2396"
-SRCREV_spirv-headers = "3814effb879ab5a98a7b9288a4b4c7849d2bc8ac"
+SRCREV_spirv-tools = "923a4596b44831a07060df45caacb522613730c9"
+SRCREV_spirv-headers = "33d41376d378761ed3a4c791fc4b647761897f26"
SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools;protocol=http;name=spirv-tools \
git://github.com/KhronosGroup/SPIRV-Headers;name=spirv-headers;destsuffix=${SPIRV_HEADERS_LOCATION} \
- file://0001-obey-CMAKE_INSTALL_LIBDIR.patch"
+ file://0001-obey-CMAKE_INSTALL_LIBDIR.patch \
+ file://0002-spirv-lesspipe.sh-allow-using-generic-shells.patch"
do_install_append() {
if test -d ${SPIRV_HEADERS_LOCATION}/include/spirv/${HEADERS_VERSION}; then
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0002-layers-obey-CXX_FLAGS.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0002-layers-obey-CXX_FLAGS.patch
deleted file mode 100644
index b1ea9dd1..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0002-layers-obey-CXX_FLAGS.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 18a990d4b6677ba7e3e7b0d4a2980864da4826a5 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Tue, 16 Aug 2016 20:23:59 +0500
-Subject: [PATCH] layers: obey CXX_FLAGS
-
-The CMakeLists earlier simply dropped all the CXX_FLAGS
-set throught he build system. This limits any chances
-of providing custom flags such as linking directories
-etc.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- layers/CMakeLists.txt | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/layers/CMakeLists.txt b/layers/CMakeLists.txt
-index b384803..c67f1df 100644
---- a/layers/CMakeLists.txt
-+++ b/layers/CMakeLists.txt
-@@ -99,8 +99,7 @@ if (WIN32)
- set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -D_CRT_SECURE_NO_WARNINGS /bigobj")
- set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_CRT_SECURE_NO_WARNINGS /bigobj")
- else()
-- set (CMAKE_CXX_FLAGS "-std=c++11")
-- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wpointer-arith")
-+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wpointer-arith")
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wpointer-arith")
- endif()
-
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0004-install-the-vulkan-loader.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0004-install-the-vulkan-loader.patch
index 99875968..68026245 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0004-install-the-vulkan-loader.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0004-install-the-vulkan-loader.patch
@@ -18,7 +18,7 @@ index a4d2b21..2790faa 100644
+++ b/loader/CMakeLists.txt
@@ -84,4 +84,5 @@ else()
add_library(vulkan SHARED ${LOADER_SRCS})
- set_target_properties(vulkan PROPERTIES SOVERSION "1" VERSION "1.0.21")
+ set_target_properties(vulkan PROPERTIES SOVERSION "1" VERSION "1.0.26")
target_link_libraries(vulkan -ldl -lpthread -lm)
+ install(TARGETS vulkan DESTINATION ${CMAKE_INSTALL_LIBDIR})
endif()
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0005-install-demos.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0005-install-demos.patch
index 0ab7a155..08f0f8f0 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0005-install-demos.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0005-install-demos.patch
@@ -35,11 +35,11 @@ index 4dc90cd..415ac2f 100644
+
+install(TARGETS smoketest DESTINATION ${CMAKE_INSTALL_BINDIR})
diff --git a/libs/vkjson/CMakeLists.txt b/libs/vkjson/CMakeLists.txt
-index fc69bb6..728ea74 100644
+index 4c0aef8..9b03d3d 100644
--- a/libs/vkjson/CMakeLists.txt
+++ b/libs/vkjson/CMakeLists.txt
-@@ -33,6 +34,8 @@ add_library(vkjson STATIC vkjson.cc vkjson_instance.cc ../../loader/cJSON.c)
- if(UNIX)
+@@ -32,6 +32,8 @@ if(UNIX)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-sign-compare")
add_executable(vkjson_unittest vkjson_unittest.cc)
add_executable(vkjson_info vkjson_info.cc)
+ install(TARGETS vkjson_unittest DESTINATION ${CMAKE_INSTALL_BINDIR})
@@ -47,7 +47,6 @@ index fc69bb6..728ea74 100644
else()
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_CRT_SECURE_NO_WARNINGS")
add_executable(vkjson_unittest vkjson_unittest.cc)
-
--
1.9.1
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0006-json-correct-layer-lib-paths.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0006-json-correct-layer-lib-paths.patch
index 42a57ee1..54d092ba 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0006-json-correct-layer-lib-paths.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0006-json-correct-layer-lib-paths.patch
@@ -28,7 +28,7 @@ index 3f2162d..c0ef9b7 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_core_validation.so",
+ "library_path": "libVkLayer_core_validation.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Validation Layer",
diff --git a/layers/linux/VkLayer_image.json b/layers/linux/VkLayer_image.json
@@ -41,7 +41,7 @@ index 97a250e..6fa3bbd 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_image.so",
+ "library_path": "libVkLayer_image.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Validation Layer",
diff --git a/layers/linux/VkLayer_object_tracker.json b/layers/linux/VkLayer_object_tracker.json
@@ -54,7 +54,7 @@ index 1c5d79b..49e5a29 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_object_tracker.so",
+ "library_path": "libVkLayer_object_tracker.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Validation Layer",
diff --git a/layers/linux/VkLayer_parameter_validation.json b/layers/linux/VkLayer_parameter_validation.json
@@ -67,7 +67,7 @@ index 899ea88..6df74f8 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_parameter_validation.so",
+ "library_path": "libVkLayer_parameter_validation.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Validation Layer",
diff --git a/layers/linux/VkLayer_swapchain.json b/layers/linux/VkLayer_swapchain.json
@@ -80,7 +80,7 @@ index 5fe0ef8..6d0b500 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_swapchain.so",
+ "library_path": "libVkLayer_swapchain.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Validation Layer",
diff --git a/layers/linux/VkLayer_threading.json b/layers/linux/VkLayer_threading.json
@@ -93,7 +93,7 @@ index 59feb59..fd6bedf 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_threading.so",
+ "library_path": "libVkLayer_threading.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "Google Validation Layer",
diff --git a/layers/linux/VkLayer_unique_objects.json b/layers/linux/VkLayer_unique_objects.json
@@ -106,7 +106,7 @@ index 59e1f89..72b77ee 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_unique_objects.so",
+ "library_path": "libVkLayer_unique_objects.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "Google Validation Layer"
--
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0007-obey-CMAKE_INSTALL_PREFIX.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0007-obey-CMAKE_INSTALL_PREFIX.patch
deleted file mode 100644
index 9bcaacd2..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0007-obey-CMAKE_INSTALL_PREFIX.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 15973dcf82c95ca05a4d76bd69785df2679876d6 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 1 Sep 2016 13:27:50 +0500
-Subject: [PATCH] obey CMAKE_INSTALL_PREFIX
-
-Unsetting CMAKE_INSTALL_PREFIX breaks relative installation
-paths. The recent updates to cmake.bbclass requires
-using the installation prefix to allow installing to
-correct hierarchy under yocto environment.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- CMakeLists.txt | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 263002e..a0d3baa 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -57,8 +57,6 @@ if(NOT WIN32)
- include(FindPkgConfig)
- endif()
-
--set (CMAKE_INSTALL_PREFIX "")
--
- if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- set(COMMON_COMPILE_FLAGS "-Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers")
- set(COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -fno-strict-aliasing -fno-builtin-memcmp")
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0008-demos-make-shader-location-relative.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0008-demos-make-shader-location-relative.patch
index 281f9069..16409b57 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0008-demos-make-shader-location-relative.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0008-demos-make-shader-location-relative.patch
@@ -19,7 +19,7 @@ Signed-off-by: Awais Belal <awais_belal@mentor.com>
2 files changed, 105 insertions(+), 8 deletions(-)
diff --git a/demos/cube.c b/demos/cube.c
-index 5b26288..b4a787e 100644
+index 6017444..f79bc59 100644
--- a/demos/cube.c
+++ b/demos/cube.c
@@ -29,6 +29,7 @@
@@ -27,7 +27,7 @@ index 5b26288..b4a787e 100644
#include <assert.h>
#include <signal.h>
+#include <unistd.h>
- #ifdef __linux__
+ #if defined(VK_USE_PLATFORM_XLIB_KHR) || defined(VK_USE_PLATFORM_XCB_KHR)
#include <X11/Xutil.h>
#endif
@@ -415,6 +416,8 @@ struct demo {
@@ -150,10 +150,10 @@ index 5b26288..b4a787e 100644
static void demo_init(struct demo *demo, int argc, char **argv) {
vec3 eye = {0.0f, 3.0f, 5.0f};
vec3 origin = {0, 0, 0};
-@@ -3093,6 +3143,8 @@ static void demo_init(struct demo *demo, int argc, char **argv) {
- 1.0f, 0.1f, 100.0f);
- mat4x4_look_at(demo->view_matrix, eye, origin, up);
+@@ -3053,6 +3053,8 @@ static void demo_init(struct demo *demo, int argc, char **argv) {
mat4x4_identity(demo->model_matrix);
+
+ demo->projection_matrix[1][1]*=-1; //Flip projection matrix from GL to Vulkan orientation.
+
+ find_bin_path(argv[0], demo->bin_path);
}
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.21.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.26.bb
index 17c989ca..0891de49 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.21.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-loader-layers_1.0.26.bb
@@ -19,15 +19,13 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99c647ca3d4f6a4b9d8628f757aad156"
S = "${WORKDIR}/git"
-SRCREV = "97e3b677d9681aa8d420c314edae96c4bf72246d"
+SRCREV = "ebf46deb849a2d4cab3382c606a9fe36699dfa78"
SRC_URI = "git://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers;branch=sdk-${PV} \
file://0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch \
- file://0002-layers-obey-CXX_FLAGS.patch \
file://0003-obey-CMAKE_INSTALL_LIBDIR.patch \
file://0004-install-the-vulkan-loader.patch \
file://0005-install-demos.patch \
file://0006-json-correct-layer-lib-paths.patch \
- file://0007-obey-CMAKE_INSTALL_PREFIX.patch \
file://0008-demos-make-shader-location-relative.patch"
EXTRA_OECMAKE = " \
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0003-obey-CMAKE_INSTALL_PREFIX.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0003-obey-CMAKE_INSTALL_PREFIX.patch
deleted file mode 100644
index 7a341b37..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0003-obey-CMAKE_INSTALL_PREFIX.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 4d1bb4d2803f7c025abf84bfed73889ac3951044 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 1 Sep 2016 13:36:38 +0500
-Subject: [PATCH] obey CMAKE_INSTALL_PREFIX
-
-Unsetting CMAKE_INSTALL_PREFIX breaks relative installation
-paths. The recent updates to cmake.bbclass requires
-using the installation prefix to allow installing to
-correct hierarchy under yocto environment.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- CMakeLists.txt | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 22fc7ad..54fa821 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -61,8 +61,6 @@ if(NOT WIN32)
- include(FindPkgConfig)
- endif()
-
--set (CMAKE_INSTALL_PREFIX "")
--
- if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- set(COMMON_COMPILE_FLAGS "-Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers")
- set(COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -fno-strict-aliasing -fno-builtin-memcmp")
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.21.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.26.bb
index 00598272..c8dd2756 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.21.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples_1.0.26.bb
@@ -14,11 +14,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99c647ca3d4f6a4b9d8628f757aad156"
S = "${WORKDIR}/git"
-SRCREV = "769f8c8455be6a131aa976a19d07d531bed9291e"
+SRCREV = "8a3afccb56cfc03d4afb06819f2b8db4bbf3364d"
SRC_URI = "git://github.com/LunarG/VulkanSamples;branch=sdk-${PV} \
file://0001-Layer-Samples-fix-build-without-BUILD_LAYERS.patch \
- file://0002-install-samples.patch \
- file://0003-obey-CMAKE_INSTALL_PREFIX.patch"
+ file://0002-install-samples.patch"
EXTRA_OECMAKE = " \
-DBUILD_LOADER=0 \
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch
index 717a090c..03ca271c 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch
@@ -78,6 +78,30 @@ index 5bc1807..4fdeb19 100644
)
set (LIBRARIES vktrace_common vulkan_replay)
+diff --git a/vktrace/src/vktrace_common/CMakeLists.txt b/vktrace/src/vktrace_common/CMakeLists.txt
+index 07ffba7..8fcbb39 100644
+--- a/vktrace/src/vktrace_common/CMakeLists.txt
++++ b/vktrace/src/vktrace_common/CMakeLists.txt
+@@ -6,6 +6,7 @@ include(${SRC_DIR}/build_options.cmake)
+ include_directories(
+ ${SRC_DIR}/vktrace_common
+ ${SRC_DIR}/thirdparty
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+diff --git a/vktrace/src/vktrace_trace/CMakeLists.txt b/vktrace/src/vktrace_trace/CMakeLists.txt
+index 63ba576..b1c56b3 100644
+--- a/vktrace/src/vktrace_trace/CMakeLists.txt
++++ b/vktrace/src/vktrace_trace/CMakeLists.txt
+@@ -16,6 +16,7 @@ include_directories(
+ ${SRC_DIR}
+ ${SRC_DIR}/vktrace_common
+ ${SRC_DIR}/vktrace_trace
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ add_executable(${PROJECT_NAME} ${SRC_LIST})
--
1.9.1
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0004-json-correct-layer-lib-paths.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0004-json-correct-layer-lib-paths.patch
index 7bc67d4b..0abb46c0 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0004-json-correct-layer-lib-paths.patch
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0004-json-correct-layer-lib-paths.patch
@@ -28,7 +28,7 @@ index c8e9c8d..450be73 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_api_dump.so",
+ "library_path": "libVkLayer_api_dump.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG debug layer"
diff --git a/layersvt/linux/VkLayer_basic.json b/layersvt/linux/VkLayer_basic.json
@@ -41,7 +41,7 @@ index b298f10..5cb893a 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_basic.so",
+ "library_path": "libVkLayer_basic.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Sample Layer",
diff --git a/layersvt/linux/VkLayer_basic_implicit.json b/layersvt/linux/VkLayer_basic_implicit.json
@@ -54,7 +54,7 @@ index 50e08c3..ca9014b 100644
"type": "GLOBAL",
- "library_path": "/etc/vulkan/implicit_layer.d/libVkLayer_basic.so",
+ "library_path": "libVkLayer_basic.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Sample Layer",
diff --git a/layersvt/linux/VkLayer_generic.json b/layersvt/linux/VkLayer_generic.json
@@ -67,7 +67,7 @@ index df8fa17..8f3b993 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_generic.so",
+ "library_path": "libVkLayer_generic.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Sample Layer"
diff --git a/layersvt/linux/VkLayer_multi.json b/layersvt/linux/VkLayer_multi.json
@@ -80,7 +80,7 @@ index 517ea7e..e81af70 100644
"type": "INSTANCE",
- "library_path": "./libVkLayer_multi.so",
+ "library_path": "libVkLayer_multi.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Sample multiple layer per library",
@@ -16,7 +16,7 @@
@@ -89,7 +89,7 @@ index 517ea7e..e81af70 100644
"type": "INSTANCE",
- "library_path": "./libVkLayer_multi.so",
+ "library_path": "libVkLayer_multi.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG Sample multiple layer per library",
diff --git a/layersvt/linux/VkLayer_screenshot.json b/layersvt/linux/VkLayer_screenshot.json
@@ -102,7 +102,7 @@ index 28773b9..e9b21fb 100644
"type": "GLOBAL",
- "library_path": "./libVkLayer_screenshot.so",
+ "library_path": "libVkLayer_screenshot.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "LunarG image capture layer"
diff --git a/vktrace/src/vktrace_layer/linux/VkLayer_vktrace_layer.json b/vktrace/src/vktrace_layer/linux/VkLayer_vktrace_layer.json
@@ -115,7 +115,7 @@ index 0dcdc6b..9ba98e6 100644
"type": "GLOBAL",
- "library_path": "../vktrace/libVkLayer_vktrace_layer.so",
+ "library_path": "libVkLayer_vktrace_layer.so",
- "api_version": "1.0.21",
+ "api_version": "1.0.26",
"implementation_version": "1",
"description": "Vktrace tracing library",
--
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0005-obey-CMAKE_INSTALL_PREFIX.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0005-obey-CMAKE_INSTALL_PREFIX.patch
deleted file mode 100644
index 59f630c9..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0005-obey-CMAKE_INSTALL_PREFIX.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From da9cd7d482206ae8bcacc1e1ac7c4e00d8c49a68 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 1 Sep 2016 13:39:44 +0500
-Subject: [PATCH] obey CMAKE_INSTALL_PREFIX
-
-Unsetting CMAKE_INSTALL_PREFIX breaks relative installation
-paths. The recent updates to cmake.bbclass requires
-using the installation prefix to allow installing to
-correct hierarchy under yocto environment.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- CMakeLists.txt | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 898b0f9..1451512 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -57,8 +57,6 @@ if(NOT WIN32)
- include(FindPkgConfig)
- endif()
-
--set (CMAKE_INSTALL_PREFIX "")
--
- if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- set(COMMON_COMPILE_FLAGS "-Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers")
- set(COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -fno-strict-aliasing -fno-builtin-memcmp")
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0006-vktrace-disable-Qt5-for-now.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0006-vktrace-disable-Qt5-for-now.patch
deleted file mode 100644
index a97a684e..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools/0006-vktrace-disable-Qt5-for-now.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From b94629ed97cfaef8a9f22d18674b3d51a0d3616f Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 1 Sep 2016 17:00:36 +0500
-Subject: [PATCH] vktrace: disable Qt5 for now
-
-We do not enable the Qt5 integration for now as
-it is not needed and has build issues in the current
-configuration.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- vktrace/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/vktrace/CMakeLists.txt b/vktrace/CMakeLists.txt
-index 21f06f7..6534d27 100644
---- a/vktrace/CMakeLists.txt
-+++ b/vktrace/CMakeLists.txt
-@@ -25,7 +25,7 @@ if (NOT PYTHONINTERP_FOUND)
- message(FATAL_ERROR "Missing PythonInterp. Install python interpreter 2.7 (on linux use cmd: sudo apt-get install python2.7)")
- endif()
-
--find_package(Qt5 COMPONENTS Widgets Gui Core Svg)
-+#find_package(Qt5 COMPONENTS Widgets Gui Core Svg)
- if (NOT Qt5_FOUND)
- message(WARNING "Qt5 dev libraries not found, vktraceviewer will not be built.\nTo enable build of vktraceviewer on Windows, set env var Qt5_Dir to\nC:\\Qt\\5.3\\msvc2013_64\\lib\\cmake\\Qt5 or C:\\Qt\\5.3\\msvc2013\\lib\\cmake\\Qt5")
- endif()
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.21.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
index 3d6536e1..6c0fcf29 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.21.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
@@ -17,14 +17,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99c647ca3d4f6a4b9d8628f757aad156"
S = "${WORKDIR}/git"
-SRCREV = "3bc2d55828e46e553da6523170f8b134f48d163d"
+SRCREV = "a60e7c2f366e213ef85a71b84946a342386fd863"
SRC_URI = "git://github.com/LunarG/VulkanTools;branch=sdk-${PV} \
file://0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch \
file://0002-obey-CMAKE_INSTALL_LIBDIR.patch \
file://0003-vktrace-do-not-link-to-internal-loader.patch\
- file://0004-json-correct-layer-lib-paths.patch \
- file://0005-obey-CMAKE_INSTALL_PREFIX.patch \
- file://0006-vktrace-disable-Qt5-for-now.patch"
+ file://0004-json-correct-layer-lib-paths.patch"
EXTRA_OECMAKE = " \
-DBUILD_LOADER=0 \