aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb')
-rw-r--r--meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb b/meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb
new file mode 100644
index 00000000..b0cdc4f0
--- /dev/null
+++ b/meta-amdfalconx86/recipes-kernel/amd-spi/kernel-module-amd-spi_1.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "This kernel module provides support for AMD SPI controller driver"
+LICENSE = "BSD | GPLv2"
+LIC_FILES_CHKSUM = "file://spi_amd.c;md5=80f01f3b969d0b1d633df6ba9edf4170 \
+ file://spi_amd.h;md5=488f986ada9e64f6b5ee6d55c269ae1b \
+ file://spirom.c;md5=ec2142faf7c64a85563fcaa129772fc0 \
+ file://spirom.h;md5=8de0c535224dbd8ecd2f40ef29c15d0a \
+ file://Makefile;md5=8ea80a6d4ae15bcf922d090df6cfdd4c \
+ "
+
+inherit module
+
+PR = "r0"
+PV = "1.0"
+
+SRC_URI = "file://Makefile \
+ file://spi_amd.c \
+ file://spi_amd.h \
+ file://spirom.c \
+ file://spirom.h \
+ "
+
+S = "${WORKDIR}"
+
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+#
+PKG_${PN} = "kernel-module-${PN}"
+
+FILES_${PN} += "${sysconfdir}"